starting problems with lt50 - Off-Road Forums & Discussion Groups
Youth ATV For discussion of all youth ATV's 125cc and smaller.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-14-2007, 10:39 AM
bri
Guest
 
Posts: n/a
starting problems with lt50

My daughter has a lt50 that had a backfire, ever since I have not been able to get it to start. I cleaned the carb out, had the cylinder honed, put new piston and rings in, and a new sparkplug. The sparkplug is sparking. I also took exhaust off and blew compressed air through it. The carb is getting fuel. I can't find anything wrong with it.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome