77 Suzuki stalls out. Could it be the float? - Off-Road Forums & Discussion Groups
Vintage Dirtbikes Discussion of all things on Vintage Dirtbikes manufactured in 1980 or earlier.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-27-2009, 10:11 PM Thread Starter
 
Join Date: Jul 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
77 Suzuki stalls out. Could it be the float?

I got a 77 Suzuki TM250. It starts great and runs for a few minutes or so, then cuts out and won't start again for a while. It ran great last year. I was just in the carb blowing it clean, and maybe hit the float. Does anyone know what the measurements should be on the float? If I had known, I would of brought it back to the factory setting. But instead I just put it back together.
strider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome