1982 yamaha IT 125 problems. - Off-Road Forums & Discussion Groups
Vintage Dirtbikes Discussion of all things on Vintage Dirtbikes manufactured in 1980 or earlier.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-27-2009, 12:02 PM Thread Starter
 
Join Date: Apr 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Question 1982 yamaha IT 125 problems.

hi i hope someone can help me . my 82 yamaha 125 starts on first kick and will idle good when you try to ride it it moves good as long as you dont give it full throtle, if you do it will bog out but wont stall and when it is neutral if you give it gas slowly it will rev up but give it gas fast and it wants to bog out .ive messed around with this thing and i cant figure it out can someone please help me. thanks
chrissz24 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 11-13-2013, 08:58 PM
Newbie
 
Join Date: Nov 2013
Location: Kentucky
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
They only made the IT125 in '80 & '81, you probably have dirt or water in your float bowl
Mattinky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome