Help me with my Suzuki King Quad 300 4X4 - Off-Road Forums & Discussion Groups
Utility/4x4 ATVs All discussions of Utility and 4x4 ATV's, quads, four-wheelers.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-14-2005, 01:51 AM
frootloop1
Guest
 
Posts: n/a
Help me with my Suzuki King Quad 300 4X4

I have a 96 King Quad. I rebuilt the engine and put it back together, rode it for a couple of days and it died. When i say died it quit, I put it in neutral hit the start button it tried to turn over but the battery was weak. Pulled it home, pulled the spark plug out, it looked good checked for spark it has none. I think stator but would like any help before going that route. I am not the best with electrical and I am thinking that could be it, but not sure. If anyone has an idea please help me out. I would really like to get it running again.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-15-2005, 07:30 PM
Apprentice
 
beekilla's Avatar
 
Join Date: Apr 2005
Location: North Wilkesboro, NC
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Help me with my Suzuki King Quad 300 4X4

Did you try a NEW (not ever used) spark plug? Also, check all the connectors to make certain they are properly secure, since you had several undone to remove the motor. Then, check to make sure your fuses are all good, and the switches are working properly. If you question the kill switch on the bar, unplug it. It supplies ground to the coil. Thus, the Quad will run with it removed. If it is anything else, you probably need to seek professional help (for the Quad, that is [img]/ubbthreads/images/graemlins/smile.gif[/img]), since you say that you are not good with electrical. It needs to be properly diagnosed before purchasing very expensive electronic components. The labor you will purchase will be well worth it. It will save you big bucks to fix it the first time... [img]/ubbthreads/images/graemlins/cool.gif[/img]
beekilla is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome