99 Recon clutch problems?? - Off-Road Forums & Discussion Groups
Utility/4x4 ATVs All discussions of Utility and 4x4 ATV's, quads, four-wheelers.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 11-29-2004, 10:12 PM
77broncosport
Guest
 
Posts: n/a
99 Recon clutch problems??

I have been riding a 99 Recon that has recently started acting up. It runs great most of the time, but now after a bit of riding you punch the throttle and the engine revs but the quad doesnt go, you let off and hit it again and you take off like normal. Another thing I have noticed recently, just this weekend, is that after a bit of riding, you hit the throttle and its almost as if the muffler gets plugged. The sound goes away, and it doesnt accelerate much. I wanted to know if anyone has had anything like this happen to their quad, or of anyone knows anything to try? The only thing I can think of is since its an auto clutch, maybe after 5 years its just worn out and needs replaced?

Thanks for any help
Matthew
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome