polaris 500 mag - Off-Road Forums & Discussion Groups
Utility/4x4 ATVs All discussions of Utility and 4x4 ATV's, quads, four-wheelers.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-06-2003, 06:15 PM
**DONOTDELETE**
Guest
 
Posts: n/a
polaris 500 mag

I am new to this board so I hope someone can help me out. I have a 2000 polaris 500 magnum with 150 hours all stock. Every time I ride in the mud my brakes start to squeak. Some times it stops after a 100 feet or so but this time it hasn't. Last time I rode the front end started squeaking pretty bad but after I got home and washed the mud off that quit but not the squeak from the brakes! Sorry for the novel but I need some advice.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-08-2003, 06:33 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: polaris 500 mag

Have you inspected the brake pads? Maybee somehting is hung up on the shoes. How about a good ole can of "disc brake quiet"? good luck.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome