Off Roading Forums banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
1989 xj limited muli-port injection 4.0L with 144,000miles, I would like to know if it normal for this engine to crank-over approx 5-6 times before it starts hot or cold, sitting for a while or just shut off nothing makes a difference to the initial 5-6 cranks to start, I also have a 4.3L 2000 blazer multiport that starts before I can even say wow!
might it be the starting modulator?
have installed new pressure regulator, fuel pump, fuel filter, plugs and wires, cleaned all air intake hoses, and O2 sensor
the next choices for me to replace are the IAC and TPS then upgrade the coil
should this engine take this long to start? I have no code puller or system monitoring scan tool so all this diagnosis is done by ear
thank you
89yj

wife screams, "what did you buy for your jeep this time?!"
I answer,"Dear it's a jeep thing, our kids don't need to eat all the time."
 

·
Registered
Joined
·
42 Posts
I was worried about the same thing, After replacing "everything" it still takes a while to start. I wouldn't worry about it aslong as it starts every time. I found that if I turn the key on and let it sit for about 30sec. then turn it over it will start right up. I've been told that the fuel system needs to build pressure in the XJ's.

 

·
Registered
Joined
·
1,595 Posts
Mine does the same. Next time I start it I will wait a bit before starting w/ the key turned. Good thought.

Kevin

'89 XJ Cherokee, stock. Wish to modify it as much as possible without spending $$ haha.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top