Off Roading Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,979 Posts
Discussion Starter · #1 ·
Ok, I swapped carbs. I swapped transmissions. And, now I am ready to pull my hair out! The Sami si running like crap! It'll idle for days without hesitation, no overheating, nothin... But, if I put it underl load it'll run like hell. the engine will backfire, sputter and just plain run like poo. In order to get anywhere I need to run the RPMs up real high and release the clutch halfway. The funny thing is, the car seems to run fine until I hit a bump or backup fast then the problems kick in. Any ideas?

 

·
Registered
Joined
·
1,435 Posts
Did you adjust the float level on the carb? Mine ran like you describe just after I rebuilt the carb (but did nothing with the float) - Finally, I got to adjusting the float level and that's all it was! If it's not getting enough gas when it needs it, it may idle ok and run sometimes, but crap out when you need it. There are two adjustments, one will stop the gas flow (lower) the other will allow more gas into the bowl (upper). Give that a try. (Sounds like you need more gas in bowl - the top of the float should be about level when the top of carb is laying upside down).

Scott Trester
1988.5 Suzuki Samurai
http://RockPile4x4.tripod.com/Scott.html
 
G

·
POSSIBLY A CLOGGED CAT CONVERTER

/wwwthreads_images/icons/cool.gif 84 cj7 Laredo /wwwthreads_images/icons/cool.gif Superior 1 piece, more to come...../wwwthreads_images/icons/smile.gif
 

·
Registered
Joined
·
2,979 Posts
Discussion Starter · #5 ·
I HATE THIS SAMURAI!!!!!

I swapped ECUs and it ran fine. I checked license plate lights - they were out (AGAIN). So, I rewired them, the car ran like crap. I pulled the ECU and put it back on. The tag lights are out and the car runs like poo...

I think it's a short in the taillights that's causing the ECU to screw things up. Tomorrow I'll pull all connectors on the taillights, run it around the neighborhood for a half an hour and see if it solves anything. If that doesn't help I'll pump a few rounds into the block and drop it off the end of the pier.

 

·
Registered
Joined
·
3,550 Posts
here now capn, b4 u pump rounds in her, i will come remove her for a small fee to cover fuel costs. hows bout that???/wwwthreads_images/icons/crazy.gif

seriously, hope it is just a short in the lights or something. good luck with it man.
BiLLy bOb


Do unto others as you want done to you!
If you pack it in, pack it out!
 

·
Registered
Joined
·
314 Posts
Please no! /wwwthreads_images/icons/shocked.gifDon't do that! Its not worth it! It's only going to make things worse for your friends who will miss a loved one... I hate it when Zuk's talk like that.../wwwthreads_images/icons/smile.gif

Hang on Crunch! We're there for you!

Yannick
1987 stock hardtop Zuk now just arrived /wwwthreads_images/icons/smile.gif
1999 S10 Zr2 4.3L 31x10.5 BFG M/T's
http://lukinfomud.homestead.com/frontpage.html
 
G

·
Car seems to run fine until I hit a bump or backup fast then the problems kick in. Any ideas?

On bump some sort electrical contact is being made and same goes for fastbackup. Check electrical wire hornace short circuit loads pulls B 12 low can cause miss fire backfire
power loss hard spots in hornace down firewall by trans following drive shaft to rear electric devices. tap on coil, dist. isolate electrical wiring system hot wire engine to bypass all electrical see how engine runs then.




 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top