Off Roading Forums banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
I have noticed lately that when I crank the wheel all the way to the left or right that the front end makes a loud pop. One pop when the steering wheel reaches lock. No noise at any other time (high speed, low speed, breaking, etc.) just hard turns. I looked back through some old posts but didn't find anything that sounded like mine. I know that the obvious answer is not to turn that hard but...

 

·
Registered
Joined
·
6,800 Posts
Axle pivot and radius arm bushings are a good place to start. Also, there is a TSB from FORD that discusses rivets on the crossmember becoming loose and allowing it to move a little, which would make a popping noise. Of course, when it comes to the front end, it could be ANYTHING :)


It's a multi-purpose passenger vehicle and it eats SUVs for breakfast...get it straight!

Muddybronco
 

·
Registered
Joined
·
1,407 Posts
Are you feeling it in the floorboards? I am curious because my 86 was doing the same thing. I thought it was the radius bushings and changed them but still doing it. I SUSPECT, now it might be slack in the body bushings causing it to pop on hard turns...

 
G

·
Discussion Starter · #5 ·
Hey Broncomania not so much "feel" it, but I was parallel parking downtown yesterday (several people on the sidewalks)and when the thing sounded off, several people looked my way. Maybe they were just admiring the Bronco all at the exact same instant...

Jeff

 
G

·
Discussion Starter · #6 ·
You might want to check the front axleshaft U-joints. Had the same thing on my old jeep and the front left was bone dry and near frozen. The loud popping noise came from when it was all cranked and finally forced the frozen joint to move.


Bakes
97 Wrangler
90 Bronco
 

·
Registered
Joined
·
910 Posts
I have the same sort of noise. Mine does it when I first pull out of a parking spot or if I'm going slow and make a quick turn ---drives me crazy--- I put a new tranny mount on I got poly radius and poly axle pivot bushings new u-joints on front and rear shafts new shocks. I checked every freakin bolt i could but couldn't find a dam thing. It seems to only happen when I make turns --on the other hand when I first sit in my seat there is a popping noise sounds like a loose bolt or floor board cracked I thought I seen a thread on this common problem with the drivers seat?? -BOB

Backyard Builder-If I ain't drivin it I'm under it!
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top