Off Roading Forums banner
1 - 9 of 9 Posts
G

·
Discussion Starter · #1 ·
I have a 95 pathfinder XE that has the oil, charge and A/T temp light come on at the same time. This just started happening recently. Only happens when the engine is hot. Driving down the road with the A/C on or sitting ideling in traffic will make it happen sooner. Sometimes all three will flash simultaneously, then go out when I get up to speed. Anybody have any ideas???

 
G

·
Discussion Starter · #2 ·
It sound like a bad conection at the firewall cannon plug. The heat in the engine bay will make it worse. It will be a bear to troubleshoot because you cant make it happen all the time. Unhook the battery. Take the plug on the left side of the fire wall off and look inside for corrosion. I there is any clean it with a wire brush. Reaply some electical grease. Then carefully reconnect it beeing sure to not bend the pins. It could be alot of things but this is the easyest to check and the most vulerable position that affects all three systems. If it dosnt help you might start looking at the ECM plugs. Good luck

 
G

·
Discussion Starter · #3 ·
Asked the nissan service guy what he thought the problem could be and he seemed positive that the altinator is about to crap out on me. Could this be possible or is he trying to screw me.
oh, and by the way, it's not the oil light, but the break, charge and a/t temp lights that are on.

 
G

·
Discussion Starter · #4 ·
Re: Oil, charge, & A/T temp light on on

Almost the exact same thing happened to my '95 Pathfinder XE. Changed the brake pads and drove it within a mile when all of a sudden all three warning lights (brake, charge, and A/T temp light) came on. I can't get it to shut off. The difference is that the lights stays completely on until the motor warms up a little bit. After it is warm, the warning lights dissapear if I have the brakes pressed. Once I let off on the brakes or in Park mode, the lights stays on again. Really confusing!
 
G

·
Discussion Starter · #5 ·
Re: Oil, charge, & A/T temp light on on

Flaguy,

The Nissan guy that told you it was the alternator is right. I checked the output voltage of my alternator after my charge, brake, and A/T Oil Temp warning light came on. I discovered the alternator is over-charging...cranking out 18.2 volts instead of the 14 volts it was suppose to be putting out. Anyway, replaced the alternator and everything is back to normal. Just thought I'd share that with you.
 
G

·
Discussion Starter · #6 ·
Re: Oil, charge, & A/T temp light on on

Thats funny I had the exact same problem happen to me on my 95 pathy just 2 weeks ago. Hot weather and in traffic the dash lights would come on, and then go out as I would get going. I replaced my alternator at the advice of the dealer and the problem went away. Must be common with these trucks. Mine has around 90K on it.
 
G

·
Discussion Starter · #7 ·
Re: Oil, charge, & A/T temp light on on

WHOLY CRAP...Jessica is still alive!!!!!!!!!!!!
 
G

·
Discussion Starter · #8 ·
Re: Oil, charge, & A/T temp light on on

Hey Tim !! Yes I'm still with you all. It's been a looooong time since I've been on the board. I see Jp is still around here to. you guys are die hards!! good to hear from you!!
 
G

·
Discussion Starter · #9 ·
Re: Oil, charge, & A/T temp light on on

OMG !!! Where have u been Jessica ?? Are u married ?? ahahahahahahahah good to hear you are OK, especially close to NY
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top