Off Roading Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2,072 Posts
Discussion Starter · #1 ·
Is my CJ\'s computer working?

How can I check to see if my CJ's computer is working? I am still working on all that emmisions crap. In the process of testing all the sensors, most of which are working, I am begining to think that the computer is not working. I am sure some of you would see this as a plus, but I am not giving up on my Carter and emissions crap yet. Is their a quick test I can do?

Thanks,

85 CJ7-4.2L,T-176,D300,2.5" lift,32"BFG MT,Durabak,York-Air,HEI?
 
G

·
Re: Is my CJ\'s computer working?

Does the servo in the carb move in and out once its warmed up? If so, the O2 sensor and computer are working. If not, make sure the following are working..

O2 sensor...measure the DC volts (use a digital)...it should vary somewhere between .5 and 1 VDC.

Temp sensors: Make sure all of them work. The engine has to be at operating temp before the computer goes into 'closed loop' control and starts controlling the servo.

Also, Make sure the Altitude wire is not grounded....you wouldn't believe how many people ground this wire because they think its a ground that was left off....how do I know?...ever hear the expersion "We learn by our mistakes"....well....how do u think I got to be so smart?

John......southern CA
84CJ7, 3"lift, 32"BFG, 4.10's, ARB Locker, Solid Axle's, Durabak
 

·
Registered
Joined
·
2,072 Posts
Discussion Starter · #3 ·
Re: Is my CJ\'s computer working?

The stepper on the carb is not moving at normal operating temp. It was moving a couple of days ago. I think the computer isn't going closed loop for some reason. As far as I know, there are only 2 sensors that tell the computer to take over, the coolant temp switch and the thermal electric switch. Both of these sensor appear to be working. I jumped the wires in the CTS connector and disconnected the TES and the computer didn't respond. Is the Computer dead? Can you think of anything else to check?

Thanks

85 CJ7-4.2L,T-176,D300,2.5" lift,32"BFG MT,Durabak,York-Air,HEI?
 
G

·
Re: Is my CJ\'s computer working?

Could be that the stepper is dead...lord knows that happened about every two years when I had my 258. Later tonight I'll look at my factory service manual and see if there are any pages I can scan for you.

LarryM
85 CJ7, 350TBI ,T19 4spd
'00 TJ Sport, NV3550 5spd, D44, Teraflex system
 
G

·
Re: Is my CJ\'s computer working?

Tom,
At this rate we will be asking you for advice.....
Your headed in the right direction....I don't have my schematic in front of me...but if i remember correctly, the coolant switch is the one on the intake manifold just in front of the carb...the TES is in the air cleaner.

Did you check the altitude wire and the O2 sensor? Also, make sure the WOT switch on the carb is set correctly. And of course, make sure all the pins in the servo connector are seated properly.

Keep us posted....this is looking like a good one.

John......southern CA
84CJ7, 3"lift, 32"BFG, 4.10's, ARB Locker, Solid Axle's, Durabak
 

·
Registered
Joined
·
2,072 Posts
Discussion Starter · #6 ·
Re: Is my CJ\'s computer working?

Here is the latest.
1. All my sensors work.
2. I don't have any vacuum leaks(all new hoses)
3. My idle mixture is perfect.

So why isn't everything working?
The stupid stepper motor on my Carter is not moving. It moves and then it sticks or stops. When I started adjusting the idle mixture the stepper was all the way forward, no matter how I adjust the idle mixture the stepper doesn't move. I can watch the voltage move up and down at the Oxygen sensor based on how I adjust the idle mixture but based on the oxygen level the computer isn't telling the stepper what to do or the stepper isn't responding. I have forced the system into closed-loop mode so that I know the computer is supposed to be working.
1 HR LATER
I let the engine cool off and connected all the sensors, when I started the engine the stepper moved to the center position and has stayed there(not moving) even though the oxygen sensor output is .1 volts(lean). I adjusted my idle and everything appears to be running well.

This system is way to complicated. If I was paying a mechanic to figure all this out I would have spent $1000 and he probably would have worked around half of the sensors and hoses and the stepper still wouldn't be working. My original goal was to get my Jeep running well based on the factory system with some help from the GM HEI. I don't think this is entirely possible and it is at this point not worth all the effort. I would still like to know if a new computer(used) would solve my problems.

What do you think?
TOM85CJ7

P.S. Does anyone have an old computer they want to get rid of, I'll pay shipping plus $10.

85 CJ7-4.2L,T-176,D300,2.5" lift,32"BFG MT,Durabak,York-Air,HEI?
 
G

·
Re: Is my CJ\'s computer working?

Tom,
My hat is off to you for doing such a detailed job of going after the problem. Too bad you are not closer to Ft. Worth....I will be there on Wed for a few days of business...I do have a spare servo that I know works....

As for the computer....most of the time when something electronic goes....its gone....you usually don't get an intermitent conditiohn like you have. I would be more inclined to think you have a bad connection somewhere. Almost all the signals for the computer go through the diagnostic connector over by our battery. I would also be willing to bet that the center position for the stepper is a default 'fail safe' position...i.e., it goes there when it can't decide where it should be....as when a sensor goes out....the idea being that it will at least let you drive it until you can get it fixed.

John......southern CA
84CJ7, 3"lift, 32"BFG, 4.10's, ARB Locker, Solid Axle's, Durabak
 

·
Registered
Joined
·
2,072 Posts
Discussion Starter · #8 ·
Re: Is my CJ\'s computer working?

Thanks for the replys,

I have been out driving, and at least my Jeep runs a whole lot better. I think I am ready for the HEI. All I need is the drive gear from 4WD Hardware. I will let everyone know how that one goes. It should be easy compared to diagnosing th emissions system. As for my carberator? What is that saying?"If it ain't broke, Don't fix it" I will wait until my Jeep stops running before touching it again.

Thanks Again,

85 CJ7-4.2L,T-176,D300,2.5" lift,32"BFG MT,Durabak,York-Air,HEI?
 
G

·
Re: Is my CJ\'s computer working?

Tom,

I have an 85 CJ7 manual tranny computer....it is yours if you want it (you pay shipping). Email me.

LarryM
85 CJ7, 350TBI ,T19 4spd
'00 TJ Sport, NV3550 5spd, D44, Teraflex system
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top