Off Roading Forums banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
I have a 76' CJ5 with a I6 258. After going about 15 miles Some stop lights, When I stop at light and then go I will here pinging from the engine in 3rd or 4th then stops when I get up to speed. Temp seems a bit high (just above half)on the old gage. Oil presure runs 15 - 20 psi at idle and about 40 - 50 psi at 50mph. Could this be from bad gas? It has a new carb on it, Unknown manufacturer. Everything else seems fine. One more thing it does not do it all the time.

Thanks in advance

Lunatic
From the land time forgot

 
G

·
Discussion Starter · #3 ·
my Eagle with a 258 does that as outside temps rise which raises engine temp a bit,all i have to do is retard my dist a tiny bit at a time
and it stops.And where it stops isnt enough retard to make any difference in way it runs.
In winter i can set it more advanced than summer.I know this isnt the "thing" to do for a fix,but it works on mine at least.something free to try anyway

 

·
Registered
Joined
·
4,618 Posts
yes.. it sounds like a diesel? you should retard your timeing.. what happens in my thought process.. is your timing slowing gets out of whack.. (is that a techincal term?) thru chain strecthing. and what not.. on all my 258's.. i could never set it to book.. i just did it by ear.. and when it ping'd i retarded it alittle.. just found a happy medium ..

survival is instinct, but living takes guts
 
G

·
Discussion Starter · #6 ·
get a 1/2" wrench and loosen the hold down bolt under the distrubtor body just enough that it will move but not to loose.First time
of doing this do it with engine off.Also it would be a good idea to "mark" both the dist. base and the mating engine block surface with either a small
paint mark or a punch mark on both so if you loosen it to much and it turns on its own,(which they will)you will have a reference as to where it originally was.
Turn the dist body clockwise as viewed from passengers side of engine.It may take only a little bit,so turn it about 1/8" and tighten it down
and road test.If you go to far it will kill the engines power.What you want is just to eleviate the ping but stay as advanced as possible.
As someone put it,"a happy medium"as it were..

 
G

·
Discussion Starter · #7 ·
Thanks for all the info. I know as much about Jeeps as I do about the mating habbits of the fruit fly. I put a higher grade of gas in and it seemed to help. I am going to put in a lower temp. thermostat in this weekend, Probably aroung 180 or 160 for the warmer weather. I am also ordering the MSD 6 next week. Summit racing is outstanding I emailed them what I had and what I wanted to and they emailed back within a day with the part #'s and prices. Total around 150.00 for the msd 6, msd coil, and bracket. Any idea's on what wires and cap I will need for this?

and THANKS AGAIN

Lunatic
From the land time forgot

 

·
Registered
Joined
·
5,140 Posts
if your timing is set to the factory spec ( assuming its a factory spec engine cam/CR and such)
and it still pings my first guess would be your EGR isnt functioning properly

ping is bad, as is timing an engine without a light, as the timing chain wears you'll gradually have to ADVANCE the timing a little maybe every other plug change to keep it within spec

lots of things to verify, firing order, vacum hose condition and routing, correct timing marks and distributer postioning..





OzarkJeep
NW Arkansas, need a Jeep T18a CJ or truck!!
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top