Off Roading Forums banner
1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
Ok heres the low down...
Ive got an AMC 401 rebuilt 2000 miles ago.
It will run really good until i romp on it
and then it starts acting funny. It will bog
really bad like its loading up and starts
pinging like bad gas at 1500-2500 RPMs...It runs
like crap and idles really low and rough. It usually
runs 180-190 temp wise and when this happens it jumps
over 200. If i dont romp on it, it will run smooth
all day long. Also it has a hard time starting up
and has a thick black smoke coming out the exaust.
There are 2 things i think might be causing the
problem but not sure... I dont have a fan shroud
so it might be getting to hot.and i have a lifter
ticking(which im getting fixxed)... Any ideas?
Thanks
Dustin

JeepChild
 
G

·
Discussion Starter · #2 ·
check the plugs then the timing. plugs will probably be covered with black soot. what carb do you have? did it ever run good since the overhaul? yea you should put a fan shroud on to keep it running cool. you'll get it running good with the experts on this board and some step by step work on your part! my 87 was also running rough and black soot. i had a choke sticking closed.
good luck
steve

 
G

·
Discussion Starter · #3 ·
Check the distributor advance mechanisms,make sure that the vacuum and centrifigal advances are opening and closing properly,make sure that nothing is preventing the advances from returning to normal position. It could be that when you get on it hard the advance weights are opening but not closing. Just a wild guess.
CTjeepnut

 

·
Registered
Joined
·
5,140 Posts
the black smoke is a too rich indicator, swap the carb for a known good one if thats possible and verify your timing

OzarkJeep
In need of a T18 tranny!
 
G

·
Discussion Starter · #5 ·
Richness taken care of with tuning the carb and changing the air filter.
Ok ive got most everything back to normal except one problem...
At high RPMs its still doing the bogging thing and its starting to
surge REALLY bad... This continues until i let completely off of
the gas... Anyone know where to get a fan shroud to fit my v8?
Would a chevy 350 shroud work? you know the ones that come
with the swap?
Dustin

JeepChild
 
G

·
Discussion Starter · #6 ·
It still sounds like you have a carb problem. The bogging down sounds like your running out of gas. Is the fuel filter clear? Its easy to check. Take it off and blow through it. There should be little to no resistance. Next, check the fuel delivery to the secondarys. If you tell us what kind of carb, I'm sure one of us can give you more exact answers. Side thought...was the float changed? A common proble is for the float to either leak (metal type) or absorb gas (foam type), thus causing the gas level in the carb to be too high.

As for the fan shroud....this might be a good time to maybe install a dual electic fan. It may be almost as cheap as the fan shroud...

Let us know what you find.


John......southern CA
84CJ7, 3"lift, 32"BFG, 4.10's, ARB Locker, Solid Axle's, Durabak
 

·
Registered
Joined
·
2,076 Posts
When you say "surging" .......do you mean that you're going down the road at a constant throttle and the engine is surging ...slightly faster .....back to normal.....slightly faster......annoying but not radical? If so this usually indicates that the fuel enrichment valve needs replacement.........but since I don't think that you can buy just the valve.....and you've got to violate a couple of gaskets in the process....you just better plan on rebuilding the carb......which seems, at least on the surface, to be the lions share of your troubles.

GeeAea

Figures don't lie ....... but liars sure do figure.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top