Off Roading Forums banner
1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
dash lights and tailights don\'t work? im stumped

84 cj7, my brothers...originally, his headlights would fade to off after about 5 minutes. hit the switch to off then on again and they would work for a few more minutes.. now, all of a sudden, his headlights work fine, but his tailights dont work. stop and turn do work though.!!!! his parking lights work up front as well. his dash lights no longer work either. i can't figure this out!! obviously his tailights and dash lights are connected somewhere, but im at a loss...

304/th400/ford 9"s front/back 7"lift 15x10/35's
it will run someday
 
G

·
Discussion Starter · #2 ·
Re: dash lights and tailights don\'t work? im stumped

my dashlights wouldnt work either it turned out to be a loose ground connection

'87 jeep wrangler in process of building
 
G

·
Discussion Starter · #3 ·
Re: dash lights and tailights don\'t work? im stumped

I would check every possible ground, clean them ALL make sure they are secure. Check to make sure none are missing....

Red 7 in the Green Mountain State
84 CJ7 / 258 / weber

torx: the root of all evil.
 

·
Registered
Joined
·
872 Posts
Re: dash lights and tailights don\'t work? im stumped

Don't fill stupid, electrical problems are bad. Tail and dash light are normally on the same circuit. Stop and turn signals are separate. I think they do this so the driver knows when they loose there tail lights. You've checked the fuses, right? With the headlight problem it sounds like a ground problem. Might also want to remove the fuses and clean all the contacts. But I'm betting on a bad body to frame ground.

Hope this helps some.
Keith

C-Ya.....................kh
 

·
Registered
Joined
·
13,432 Posts
Re: dash lights and tailights don\'t work? im stumped

The only part (aside from the ground) in common with these circuits (tail lamps and dash lamps) is the headlight switch. Pull the swtich, find the feed for the tail lights and apply 12 volts to that contact. If the lights work, the harness is good, and check the switch.

 
G

·
Discussion Starter · #6 ·
Re: dash lights and tailights don\'t work? im stumped

thanks..ill try this tomorrow in the sweltering heat...it probably is a rusty ground or incomplete contact. thanks

304/th400/ford 9"s front/back 7"lift 15x10/35's
it will run someday
 
G

·
Discussion Starter · #7 ·
Re: dash lights and tailights don\'t work? im stumped

I would also guess a bad-relay. My fog light relay got soaked.. and the lights would go on when the switch was off... and vice versa. I'd have to toggle it a few times, turning my mains on/off a couple times, before everything would stay off.

One symptom was dimmed headlights...

I took the relay out (disabling my fogs), and the problem cleared up.

Worth a try...

Sam88Jeep

'88 YJ 4.2L, 32/36 Weber, HEI, 2.5" spring lift, 31" BFG ATs.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top