Off Roading Forums banner

Big Ignition Troubles

981 Views 14 Replies 3 Participants Last post by  **DONOTDELETE**
I have had this problem for a while now....My 89YJ with the 4.2 will randomly stall for no reason at all. It will do it at any temperature or engine speed, and I know its the ignition because, when the engine dies, the tach drops to zero, even though the engine is still moving (its a 5-speed). Then it wont start for about an hour or so, but if you leave it sit for about an hour, it always starts back up. We pulled the main wire from the coil once when it died, and cranked it only to find that it had no spark, which definitely means that it is an ignition problem. Well, to date, I have replaced the Ignition Control Module, the Ignition Pickup (under distributor cap), Coil, Cap, wires, plugs, battery cables, and we have looked for any shorts in the system, or broken or corroded wires, and found nothing, also a friend tipped us off that sometimes the distributor doesnt make good ground, so we used a wire to ground the distributor case to the block, but that still didnt work. The engine itself is all stock, it still has the original carb and everything. This is totally stumping us, and we are about ready to sell it, as it isnt trustworthy beyond about 5 miles.

89YJ 4.2 5"lft 33"Firehawk ATX
1 - 15 of 15 Posts
do you have that little motorcraft electronic brain box for the ignition?

I know you said you replaced it, but it isnt getting hot is it? like mounted next to something to heat it up? they dont like htat much.

If youve truley got it narrowed down as far as no spark when it stalls, then I would do this:

buy another brand new duraspark IGN box, go ahead and mount it under the hood near the original ( so you can test really quickly with no cool down time), next time it stalls plug in the NEW box and see what it does, I realize your risking $22 but you need a spare anyhow..

there is a guy on this BBS who knows quite a bit about Ignition systems, i cannot recall his name, but Ill bet if you ask around he would be happy to help you out!

In need of a T18 tranny!
Your Idea does make sense because the Ignition Module IS under the coolant overflow bottle, but the strange thing is that it has been there for all the 11 years that this Jeep has been on the road, my question is, why does it do it now, and not from the very start, 11 years ago?

89YJ 4.2 5"lft 33"Firehawk ATX
heck, I dont know, Ive just assumed the build quality of those boxes varies widely, and some might not get a full, or good epoxy dip, and might be more open for moisture or heat..

keep in mind this is all purely speculation on my part, it could be your Turbine gasket for all I know.

I just know lots of guys , including myself, who have chased intermittant IGN related things on these beast before it was common knowledge that these ignitionboxes dont go bad all at once.

In need of a T18 tranny!
Thanks for your help, we're gonna try relocating the box tomorrow, and mounting my old IGN module under the hood too, so if it does stall, I can quick switch over and try the other one. I'll post what happens, hopefully this is the end of this thread, but who knows????

89YJ 4.2 5"lft 33"Firehawk ATX
The tip here for me is the tach going down before the ignition does...
I've seen tach's go down and ground out the ignition before....
Unhook the tach, and see if it still does it...

Overloaded ignition switches will do the same thing.
Heat up, quit, and start working again when it cools down, or you hit the key a few times and scratch the carbon off of the contacts on the ignition switch...

The easy way to find that out is to wait until it quits again, leave the key 'ON' and jump out, disconnect the two wire plug at the Module, and see if you are getting voltage at the harness side of the White wire connection.
You can also see if there is 12 volts getting to the positive side of the coil.
(I have a test light I use, it's quicker.)

If it does, here is a test harness diagram that can be made from a few rolls of colored wire and INSULATED male and female spade connectors.
Make this harness, and it rules out the factory wiring harness and your engine accessories, like emissions controls and your tach....
(See Attached)

Some tests for your wiring harness...

1. Unhook the two wire connector from the Dura Spark module.
Test the HARNESS side of the connector...
Turn the Ignition Key 'On', and voltage test the White wire to the Dura Spark module. It should be 12 volts.
Anything less than 12 volts and it will cause the problem you describe.
Current starvation will over heat the internals of the module.

2. The Red wire in the same connector should be 12 volts hot when the engine is cranking.
It is perfectly fine for this wire to remain 'Hot' while the engine is running. Some do, some don't.

3. If all tests go well,
Clean both sides of this connection thoroughly, fill with dielectric grease, and reconnect.

4. Unhook the Four wire connector from the Dura Spark module.
The Module Black wire is the Dura Spark Module's ONLY GROUND.
Poor ground will cause the problem you describe.

Resistance tests are for the harness side of the connector for the next two tests...

5. Do a resistance test between the Violet Wire and the Orange Wire. 400 to 800 Ohms is acceptable.

6. Do a resistance between the Black wire and the engine block.
There should be no resistance.

7. If all tests go well,
Clean both sides of the connector thoroughly, fill with dielectric grease, and reconnect.

8. Check the coil.
Primary resistance should be 1.1 to 1.5 Ohms for a stock can coil. ( 0.40 to 0.45 Ohms for TFI coils)
If your resistance is higher or lower, get a new coil.

9. Do a resistance test between the coil negative side of the connector (Green Wire) and the Green wire Module connection in the harness.
There should be no resistance.

10. Clean and inspect your coil connections, reconnect.

10. Disconnect the Distributor wiring at the connector.
Do a resistance test between the Violet and Orange wires. 400 to 800 Ohms is acceptable.

11. Do a resistance test between the Black wire and the engine block.
There should be no resistance.

12. If all tests go well,
Clean both sides of the connector thoroughly, fill with dielectric grease, and reconnect.

So Many Cats, So Few Recipes...


See less See more
Thanks very much for the info. I will run the checks tomorrow. I relocated the (recently purchased) ignition control module (ICM) from under the radiator overflow bottle to the inside fenderwell. I also mounted the original ICM that I thought was bad along side of it. I ran the Jeep for about 20 minutes and shut it off. Came back in ten minutes and it wouldn't start. Reconnected to the original ICM and it started. Went right back to the ICM that wouldn't allow it to start and it wouldn't start. Switched back to original and it started. Will continue testing tomorrow. Thanks alot for your information.

89YJ 4.2 5"lft 33"Firehawk ATX
whats up with that TeamRush?

low input voltage overheating it maybe?

In need of a T18 tranny!
Low voltage is the symptom... Possible causes include...

Bad ignition switch, (not the key switch)
Bad connections in the fuse box,
Bad wiring harness,
Bad or corroded connectors,
AC voltage in the system,
A Hex placed on you by an evil Jeep witch,
Bad ground,

If he has two modules doing the same thing, it very well could be low input voltage.
It sounds like he has it narrowed down to the module.

If it were me, I'd wire the two wire connector (White Wire in particular) on the Dura Spark module to the positive on the battery, and run the jeep for a while...
Just see what happens...
If it doesn't quit, it's most certainly the wiring harness...
If it does quit, it stands a good chance of being the module.

I'm seeing a lot of that in e-mails from guys with failed modules in Jeeps...
(they say one goes bad, then another, then another...)
Seems to be some sort of design flaw in the wiring harness.
It's usually traced back to where the power supply and resistor wire connect together in the wiring harness, but you have to unravel 50" of ignition coil harness to find it...
Real pain in the A$$!

It could also be a bad alternator leaking AC voltage into the system...
Modules and such don't take kindly to AC voltage...

I've had a few of the Ford harnesses fail with the 'Run' power supply, (White Wire) and choke the module to death, to it's not unheard of...
They try to run off of the 'Start' (Red Wire) wire full time, and that always results in module failure.
Most of the time it's faulty connections...
Motorcraft had REALLY CRAPPY connections on their stuff...
You have to clean them just SUPER CLEAN, and Lots of dielectric grease is mandatory, and ANY moisture is bad...

It could also be the second module is just able to function at lower voltages, or hasn't had time to heat up and quit.

I've already given him the test procedures to find the general location of the problem,
Let's just wait and see how he does...

So Many Cats, So Few Recipes...
See less See more
Well, I relocated the ICM, as I said earlier and everything seems to be doing good. I took the Jeep to work today, had to drive to the different buildings for random Networking tasks and the Jeep made it through just fine. It seems as if I got a couple of crappy modules, I tested the voltage at the coil on the module that dies ALOT, and it was not within the recommended voltage, the other coil is closer to the right voltage, but still off, so I think Im gonna just buy a new module and run that, and keep the other "good" module in case I need to limp the Jeep home on the old module some day. I think that Im gonna run those tests that TeamRush posted to this thread (Thanks ALOT, by the way) just to be sure that I have everything straightened out. I'll do it sometime this week, between the girlfriend and work though it will probably be at 3 in the morning (the best wrench turnin' time anyways). I'll let you know what happens.

Well, thanks SO MUCH for all your help, guys, you dont know how much I appreciate it, its so good to have a Jeep that is reliable again. Now, if only it would warm up, so I could put the soft top and the 33's back on it :)

Thanks again,

89YJ 4.2 5"lft 33"Firehawk ATX
See less See more
Well, seems like everything is working good on the 'ol Jeep, I now have 2 Ignition Modules, and the Jeep has been ruinning great for the last few days. I ran some of the tests that TeamRush posted, and everything is coming out fine now. By the way, people on this board have mentioned that you can get an Ignition Module for something like $20, I cant figure this out, I got mine at a "Friends Discount" and it still cost me $70!!! This was at a CarQuest Auto shop. I was just wondering where everyone buys their modules for over 1/3 of the price Im paying??

Well, TeamRush, OzarkJeep, and all the other people, thanks alot for your help, this problem had put my Jeep out of commission for close to 2 months now, and its great to have it back. Im goin out for a cruise in it right now, but I'll be back to give my 2 cents on this board, as always :)

89YJ 4.2 5"lft 33"Firehawk ATX
Hey guy,

Im glad its working now, well never know EXACTLY what the problem might have been..

the electronic modules used to be $20 at Wal Mart.. ( its listed as Ford, any 80s Ford gas burner should fit the bill)

Oreillys, they list 3 boxes, starting at *19, going to 33, the warrenty gets better as you go up..

77 CJ5, in a bunch of pieces right now
damn...$70!! Everyone I have seen has been between $17 and $25! Does it have gold plated plugs?


Better come with gold everything and a blond with big ta-ta's for $70!!

Advanced auto has lifetime warranty for something like $16 and Auto Zone is under $20.
The only good thing about car quest is they carry the Standard Electrical line, so you can get the harness side of the connectors there.
(but they are expensive as all hell. Most of the harness side of the connectors are $12 to $20.)

Glad to hear you are getting it figured out...
Later folks, Aaron.

So Many Cats, So Few Recipes...
Checker Auto $19.95. You burn it they replace it.
NAPA $64.95 I did not ask but I bet no return.

1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.