Off Roading Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
95 Cherokee 4.0 Overheating. New T-stat Water pump. NO circulation Thru radiator. I have jacked it up to try and burp the system, ( it is not a sealed system) If I start it with the radiator full and the cap off it bubbles out the neck. I have disconnected the hose from the thermostat housing to the heater core while it is running and all I get is steam. I have even pulled the Thermostat and it is still not circulating. Heater core and radiator are not plugged I have flushed them both. Please help My daughter needs her jeep to get the kids to school.:mad:
 

· Registered
Joined
·
4,117 Posts
I would make sure you have the correct water pump. There were 2 different pumps made for the jeep 4.0, on one the pulley and impeller rotate one way to circulate coolant, on the other it is spun in the opposite direction, if I recall correctly it had to do with different options and routing of the serpentine belt. And my apologies for not giving a response sooner, but I RARELY come to this forum anymore, once in a great while just for GP's :)
 

· Registered
Joined
·
4,117 Posts
Part of why I stopped hanging around here much, people hardly ever come back and let ya know if they were able to solve their problems with the help they received. Makes a guy feel unappreciated and unneeded :eek:ldcodger:
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top