Off Roading Forums banner
1 - 2 of 2 Posts
G

·
Discussion Starter · #1 ·
I've got a 92YJ 4.0L with a problem. A few weeks ago it died in the middle of the road, and wouldn't start until 2 days later when I had it towed to the dealer garage. Of course the service tech got no codes and said he didn't have a clue.

One of you guys posted that it may be a Crankshaft Position Sensor. I called back the service dept. and they agreed, but said to wait and see if it happens again.

Well, of course, it's doing all the time now. It died driving down the road probably 10 times on my way home from work yeasterday. Only now it starts right back up everytime, even though engine somtimes will surge violently or idle up to 1500rpm. So I call back the Service Dept and he says he doesn't think its the Crankshaft Position Sensor anymore, but he doesn't have any other ideas. Ya, that service dept is a big help.

I already changed all the plugs, wires, cap and rotor, and have swapped out coil. I'm probably going to change that Crank Pos. Sensor, which is around $60, but thought I'd get all your opinions first.

—I cycled the ignition switch in order to get a trouble code. I get; 1flash- 2flashes--3flashes-3flashes--5flashes-5flashes. Is this 3 seperate codes of 12,33 and 55 or am I way off base.

Any HELP, IDEAS or ADVICE would be greatly appreciated.

 

·
Registered
Joined
·
1,181 Posts
It could be as simple as a clogged fuel filter. That's what it sounds like to me, helps explain the fact that it has been getting worse too. The last fuel filter I clogged would kill the engine while I was cruising, I'd pull over wait a minute and crank it right back up! Try a new filter just incase, only $10 or so. Can't explain the engine "surges" though??

/wwwthreads_images/icons/cool.gif Big Ed
'88 YJ, 4" susp,3" body,33's,283 Chevy V8,TH350,4.11's,D30,D35c
 
1 - 2 of 2 Posts
Top