Off Roading Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, Im new to the site and to my 1984 nissan 720 4x4 with 2.4 engine,it is stock other than a Weber 32/36 DGV carb ( new ). I have only driven the truck a few times and it seems to run well on flat ground ( not a powerhouse but runs well for 6700ft elevation ) I live in the mountains so uphill grades are a daily thing. Yesterday I took the truck for a drive and attempted my first uphill grade ( only about a 6% grade ) once I started to give it gas to climb the hill the darn thing started cutting out/missfiring etc... I quickly turned around went back down the hill and onto flat ground and it ran fine so I tried it again, and once again it started cutting out as soon as a load was put on it. I have a full tank of fuel, brand new electric fuel pump,filter etc... The float is properly set and to be honest Im running out of ideas. Could someone PLEASE HELP??? Im new to the Nissan and I have read several posts of people with similar issues but haven't seen an answer yet, Im not a mechanic by any means but I know if you have fuel,air and spark it should run on flats,uphills whatever. So if anyone could please give some input on this I would really appreciate it, I believe when in doubt ask for help so thats what Im doing. Thanks ahead of time for anyone taking the time to share input on this issue.:shocked::confused:
 

·
Registered
Joined
·
38 Posts
lo fuel pressure under demand/plugged fuel filter. Check that all plug wires are well seated and that the distributor cap/rotor are installed correctly
 
1 - 3 of 3 Posts
Top