MSD...HELP!! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-24-2001, 03:57 PM
**DONOTDELETE**
Guest
 
Posts: n/a
MSD...HELP!!

Just installed my MSD6A and It doesn't work. Did the static test on the unit (coil wire 1/2" from ground and touch trigger wires together) and it fired. When I hook everything back up stock, it runs fine. The problem seems to be in the triggering from the distributer. This is 88 carbed unit. I determined which wire was positive from the distributer by checking for a hot lead with the key on. I could try switching positions with the lavender and green wires at the dist. but I'm afraid I'll fry my pick-up module in the dist. Do I need an adapter because of the elecronic tach? Should I try reversing the trigger wires? Should I just wait until Wed. and call the MSD tech line? By the way, I did do a search before posting. thanks mucho, clyde

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-24-2001, 04:03 PM
Moderator
 
dparker's Avatar
 
Join Date: Jan 2001
Location: Arkansas.Paragould
Posts: 4,427
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: MSD...HELP!!

i have the msd instuctions for a zuk somewhere i will see if i can hunt them up real quick. im running a pro comp tach and i dont need do adapter

and yes if you dont no it buy now i cant spell LOL!

dparker is offline  
post #3 of (permalink) Old 12-24-2001, 04:22 PM
Moderator
 
dparker's Avatar
 
Join Date: Jan 2001
Location: Arkansas.Paragould
Posts: 4,427
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: MSD...HELP!!

You have seven wires coming out from your MSD 6A

One heavy red - goes to 12v
One heavy black - goes to good ground point
small red - this goes to the wire that was originally on the coils terminal (or ignintion switched 12v)
orange - goes to coil
small black - goes to -coil
white goes to the wire that was originally connected to the -coil IF you are using your original ignition amplifier. im pretty sure this is how mines hooked up


and yes if you dont no it buy now i cant spell LOL!

dparker is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 12-24-2001, 04:31 PM
Moderator
 
dparker's Avatar
 
Join Date: Jan 2001
Location: Arkansas.Paragould
Posts: 4,427
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: MSD...HELP!!

is this how you have it hooked up? http://www.msdignition.com/pdf/pdf16.pdf

and yes if you dont no it buy now i cant spell LOL!

dparker is offline  
post #5 of (permalink) Old 12-24-2001, 05:02 PM
Moderator
 
dparker's Avatar
 
Join Date: Jan 2001
Location: Arkansas.Paragould
Posts: 4,427
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: MSD...HELP!!

im pretty sure thats how i hooked it up i didnt use the tach input though i had to a eamil form msd tech on how to get my pro comp tach to work with the msd and the 4 cyl zuk .
if you cant figure it out buy tonight im going out to the shop and i can look and take some photos that way you well no for sure .i would right now but just left there been up all night rebuilding a honda legend v-6 what PITA!

and yes if you dont no it buy now i cant spell LOL!

dparker is offline  
post #6 of (permalink) Old 12-24-2001, 05:16 PM
Keyboard Implanted
 
Join Date: Sep 1999
Location: Eastern Tennessee
Posts: 3,550
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: MSD...HELP!!

on my msd box, (msd6A ifn i remember right) theres a spot on the msd box itself where the tach hooks directly up to the msd box.
BiLLy bOb


Head chef for izook events
Do unto others as you want done to you!
If you pack it in, pack it out!
Billy Bob is offline  
post #7 of (permalink) Old 12-24-2001, 11:31 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: MSD...HELP!!

I hooked it up according to the instructions except I didn't know which of the wires from the pickup in the dist was pos. and which was neg. I turned the key on and the black w/white tracer was hot so I used that as pos. and the brown as neg. Since I have the Suzuki electronic tach I'm wondering if that is causing me problems in triggering the ignition.

post #8 of (permalink) Old 12-25-2001, 09:03 AM
Moderator
 
dparker's Avatar
 
Join Date: Jan 2001
Location: Arkansas.Paragould
Posts: 4,427
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: MSD...HELP!!

Billy Bob

i have that on mine too but for some reason on the procomp i had to hook it up to the negative side of the coilthats the only way it would work .


i dont no what to tell you about the factory tach seeing how i didnt have 1 thats why i hooked up the procomp tach if you need some photos of my wiring let me now

and yes if you dont no it buy now i cant spell LOL!

dparker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome