clutch problem (update) - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-13-2001, 08:05 PM Thread Starter
 
Join Date: Feb 2001
Posts: 1,316
Thanks: 0
Thanked 0 Times in 0 Posts
 
clutch problem (update)

i asked this board a couple of days ago if anyone had any ideas as to why my bro's zuk was eating clutch cables. after adjusting a new clutch cable several times, the clutch would still not disengage. all of this was done in the dark outside.

now for the update..
i thought about what could be wrong and figured that the release bearing was getting hung up on the tranny input shaft which was suggested by dparker. so today in the daylight i went out prepared to pulll the tranny once again and low and behold the problem was discovered as i started disassembling the thing, the motor-to-tranny bolts were very loose and the top drivers side one was completely gone! i put in two new bolts for the top and two new nuts for the bottom and torqued it all tight. now it drives great again. thanks again for all the suggestions and especially dparker who sent me in the right direction.
jerry

blue_zuk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome