Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   Suzuki GEO All (https://forums.off-road.com/suzuki-geo-all/)
-   -   clutch problem (update) (https://forums.off-road.com/suzuki-geo-all/98643-clutch-problem-update.html)

blue_zuk 12-13-2001 07:05 PM

clutch problem (update)
 
i asked this board a couple of days ago if anyone had any ideas as to why my bro's zuk was eating clutch cables. after adjusting a new clutch cable several times, the clutch would still not disengage. all of this was done in the dark outside.

now for the update..
i thought about what could be wrong and figured that the release bearing was getting hung up on the tranny input shaft which was suggested by dparker. so today in the daylight i went out prepared to pulll the tranny once again and low and behold the problem was discovered as i started disassembling the thing, the motor-to-tranny bolts were very loose and the top drivers side one was completely gone! i put in two new bolts for the top and two new nuts for the bottom and torqued it all tight. now it drives great again. thanks again for all the suggestions and especially dparker who sent me in the right direction.
jerry



All times are GMT -5. The time now is 12:49 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome