Please help - broke down - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-16-2001, 12:26 PM
SPAMurai
Guest
 
Posts: n/a
Please help - broke down

Driving through Raleigh today - switched on the heater fan, and immediately lost power. Coasted off the road and parked. AAA got me home.
motor turns over fine, but it won't start. with key in "on" position, wipers & heater fan don't work. headlights do work. all fuses in the fusebox are fine.
any ideas? can anyone in raleigh help me out?? please?! my sister is visiting on wednesday, and needs to use the car all week.
please help if you can. thanks,
steve o' home: 828-0557


'87 4-Runner, 31's, Downey headers & 2.5" cat-back, Flowmaster, 3" lift, and locked.
'87 SPAMurai, 30's, 2" lift, to be locked soon.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-16-2001, 02:05 PM
 
Join Date: Sep 2000
Posts: 695
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Please help - broke down

Check for a blow fusable link.

Marc Haught
[email protected]
www.serioussami.rockcrawler.com
Sami is offline  
post #3 of (permalink) Old 09-16-2001, 02:11 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Please help - broke down

There is a ground wire for the Carb. close to the battery, make sure it is still good. Try unplugging all the plugs and check for good contact and plug them back in good. Friend had one do the same thing to him, all he did was unplug everthing one at a time and plug it back in good. Work like a champ.

Hope this helps.



jmoe [img]/wwwthreads_images/icons/crazy.gif[/img]
86 HD, SPOA, 2in S/R, P/S, misc.......
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-16-2001, 08:58 PM
Keyboard Implanted
 
Nowhere's Avatar
 
Join Date: Mar 2001
Location: Altamonte Springs FL
Posts: 3,333
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Please help - broke down

I'd bet .25 that the ground has gone bad on the zook.. Easy fix. On the distributor, replace the little 36 guage (hehehe) wire that will ground the motor to the suzuki frame. Mine was freaking out as far as the electrical works and this fixed it for me. Check to see if you have sparks also on the coil.

I'm LOCKED!
Got zook?I do,88.5 spoa'd on 29'shttp://www.geocities.com/bik3r
Nowhere is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome