Found the problem with my faulty driveline - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-13-2001, 05:21 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Found the problem with my faulty driveline

Hey,

I posted a question a week ago about my faulty driveline from my 89 Samurai...
Well, I found the problem!!!!!!

It was a worn cardan(or cross) coupling in the driveshaft from the Trans to the T-case.

We found it buy the following procedure:
----------------------------------------
We checked if the drive shafts(3x) had play,
no play > Coupling OK!
When we rotated the shaft with the T-case in 'N', we could feel a hard point, so we removed it
The input axle from the T-case rotated smoothly > T-case OK
so it was the driveshaft or the transmission
I hoped of course that it was something with the driveshaft because i didn't like to do an overhaul of a transmission!
we removed and then checked the driveshaft and found that one axle of the Cardan (cross) coupling was very stiff
> problem found!

A new "+" is all I need to make my samurai back on the roads (and off course riding trails, because that's why 4x4 or supposed te be build, wouldn't you say so?!)

Thanks for the advice!
Danny

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome