Cams and EFI - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-11-2001, 10:44 PM Thread Starter
 
Join Date: May 2001
Posts: 518
Thanks: 0
Thanked 0 Times in 0 Posts
 
Cams and EFI

I am fixin to put my 1.6 8v into my Sammi. I figured since I had the engine out , I would upgrade the cam. After doing a CAM search on this BBS and reading everything, I decided on a low end cam from Asian Auto Parts. A few days after I ordered it, I stumbled onto a New thread here on the suzuki Forum. There was a lot of conflicting info about using a performance cam with the TBI EFI on the 8v 1.6L (my engine). It was a conversation the occured late into the posting so many of you may not have seen it. I did a different search on this BBS and found that there is very little info on cams with EFI. The general concensis is that it is best to stay with the stock cam (the ECM/ injector combo cannot compensate for the system change caused by a performance cam), but there was talk of possible work arounds.

I am curious if anyone here has had any experience with this. Any thoughts, ideas or even rumors would be appreciated. This might be an opportunity to create a post on this subject that could easily be searchable by future readers.




RoBeRt
"Reality goes on without me!"
whazoo is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-12-2001, 12:07 AM
Can't Get Enough
 
Join Date: Aug 2000
Location: Waldorf, Maryland
Posts: 1,154
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Cams and EFI

If you install it and it doesn't work out as you expected, let me know and I will buy it from you. I have been holding off on installing a cam until I go through my next emissions test. If I pass (cross my fingers) I will push the boundaries a little more. So far with the Mikunis, the engine still burns very clean. I have talked to a emissions inspector and he said as long as I still have the convertor installed I should pass with no problems. We'll see next September...

zoomy4 is offline  
post #3 of (permalink) Old 08-12-2001, 01:56 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Cams and EFI

if they don't work i'd buy'em also!

Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-14-2001, 08:36 AM
patchizuki
Guest
 
Posts: n/a
Re: Cams and EFI

im not much help but, when you get the answers let me know as i have the 1.6 efi on my 1.3. would love to be able to put a cam in it.
jason gnatowsky

post #5 of (permalink) Old 08-14-2001, 08:39 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Cams and EFI

I've installed the Iskendarian torquer cam on a 1.6 injected Samurai before. Worked very well. After we finished building up the rig for the customer, we could chirp 32" tires in 2nd gear. Cruised 75-80 on the interstate too without trouble.

http://www.rocky-road.com
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome