Missing Thermostat - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-09-2001, 12:48 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Missing Thermostat

With the thermo removed, shouldn't water always be flowing regardless of the temp?

Neal the Zukiguy

"If it is '...a Jeep thing...' I hope it isn't contagious"

88.5 Weber carb, header, 4.16 t-case, 31x10.5 M/T's, 2" s/r, 2" bod lift, front tube, Swift seats
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-09-2001, 01:06 PM
Keyboard Implanted
 
Yankee Tim's Avatar
 
Join Date: Mar 2000
Location: Northern Catskill Mountains, NY
Posts: 4,756
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Missing Thermostat

yes

<font color=blue>Yankee Tim</font color=blue>[img]/wwwthreads_images/icons/cool.gif[/img]
Yankee Tim is offline  
post #3 of (permalink) Old 08-09-2001, 01:14 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Missing Thermostat

My coolant didn't move until it warmed up. it did raise and lower with the rpms when i rev'ed it, but it didn't start flowing until it got warm.

What would cause this?

This episode is getting so frustrating!

Neal the Zukiguy

"If it is '...a Jeep thing...' I hope it isn't contagious"

88.5 Weber carb, header, 4.16 t-case, 31x10.5 M/T's, 2" s/r, 2" bod lift, front tube, Swift seats
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-09-2001, 02:40 PM
Keyboard Implanted
 
Yankee Tim's Avatar
 
Join Date: Mar 2000
Location: Northern Catskill Mountains, NY
Posts: 4,756
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Missing Thermostat

That's when the stat opened up and allowed the water to flow.

<font color=blue>Yankee Tim</font color=blue>[img]/wwwthreads_images/icons/cool.gif[/img]
Yankee Tim is offline  
post #5 of (permalink) Old 08-09-2001, 02:42 PM
I Do This For The Glory
 
JEEPN's Avatar
 
Join Date: Dec 1999
Location: Nobleboro, Maine
Posts: 7,958
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Missing Thermostat

I think he's saying he doesn't have a thermostat and it does this, am I correct?

JEEPN
Winter Harbor, Maine
'81 CJ-8 Scrambled, It's a Jeep, Chevy, IHC kinda thing!
'88.5 Zuki, 5" Calmini, Locked, Swamped, Rolled, and just generally broken in right!
JEEPN is offline  
post #6 of (permalink) Old 08-09-2001, 03:53 PM
 
Join Date: Aug 2000
Posts: 624
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Missing Thermostat

That's what I was thinking....

In general, when you run an engine without a thermostat, it will run Hotter than with one installed. The water passes through the system so fast, it does not allow it to pick up enough heat to cool the engine. Although eventually all the coolant gets hot, but it is passing through the radiator so fast, it does not cool it back down as it was designed.

Have you had your radiator shot with an infrared temp gun? You can use one to test the radiator temp in various locations on it. That could show you if there are clogged tubes.

HTH,

OILBURNER [email protected]
OILBURNER is offline  
post #7 of (permalink) Old 08-09-2001, 04:12 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Missing Thermostat

My thermostat is not installed. The coolant is NOT moving when cold. Only when it warms up does it start to move like normal, but after about 10 miles of driving, it begins to boil and vent. Gonna pull off my water pump and look at it.

Neal the Zukiguy

"If it is '...a Jeep thing...' I hope it isn't contagious"

88.5 Weber carb, header, 4.16 t-case, 31x10.5 M/T's, 2" s/r, 2" bod lift, front tube, Swift seats
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome