1.6 Conversion Clutch Problem - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-06-2001, 02:28 PM
**DONOTDELETE**
Guest
 
Posts: n/a
1.6 Conversion Clutch Problem

Hey guys. I just installed a 1.6 from MXNHD. Great engine! Got the adapter from Brent @ TrailTough and installed my 1.3 flywheel and clutch onto the 1.6. I can't get the clutch to work! Through-out bearing is OK, but won't depress the pressure plate. I'm thinking maybe I put the disc in backwards??? What d'ya think?

br549
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-06-2001, 03:15 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 1.6 Conversion Clutch Problem

It's possible that you got it in backwards. Did you connect all of the cables in the right places? If you didn't it won't work. I'm running the 1600 16v in my rig and the clutch does feel different than when it was stock.
ROB

post #3 of (permalink) Old 08-06-2001, 03:30 PM
Keyboard Implanted
 
zooky's Avatar
 
Join Date: Nov 1999
Location: New Hampshire
Posts: 2,844
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 Conversion Clutch Problem

double check the throw-out bearing. I had the same exact problem when I did my conversion, it got cocked and bound its self up.

zooky is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-06-2001, 04:28 PM
Keyboard Implanted
 
DannyL's Avatar
 
Join Date: Sep 1999
Location: Ormstown, Quebec, Canada (near Montreal)
Posts: 2,224
Thanks: 0
Thanked 1 Time in 1 Post
 
Re: 1.6 Conversion Clutch Problem

<font color=red> got cocked and bound its self up.<font color=black>


OH DO I HAVE A ONELINER FOR THAT!!!

Not for here of course...........

DannyL

http://www.partszuki.homestead.com
DannyL is offline  
post #5 of (permalink) Old 08-06-2001, 06:16 PM
Keyboard Implanted
 
Yankee Tim's Avatar
 
Join Date: Mar 2000
Location: Northern Catskill Mountains, NY
Posts: 4,756
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 Conversion Clutch Problem

Danny, you took the words right outta my mouth.

<font color=blue>Yankee Tim</font color=blue>[img]/wwwthreads_images/icons/cool.gif[/img]
Yankee Tim is offline  
post #6 of (permalink) Old 08-06-2001, 07:12 PM
Keyboard Implanted
 
zooky's Avatar
 
Join Date: Nov 1999
Location: New Hampshire
Posts: 2,844
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 Conversion Clutch Problem

DAMN...

zooky is offline  
post #7 of (permalink) Old 08-07-2001, 01:07 AM
 
Join Date: Apr 2002
Posts: 92
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 Conversion Clutch Problem

Try indexing your clutch arm on the splines. A must do with this swap. Good luck.

Kerry
87 Zuk
KHalls1 is offline  
post #8 of (permalink) Old 08-07-2001, 04:02 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 1.6 Conversion Clutch Problem

Thanks for advice, guys. I already checked the throw-out bearing and re-indexed the clutch arm on the splined rod. I guess I have to bit the bullet and pull the tranny so I can check the disc.

br549
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome