Oops! Hidden damage - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-20-2001, 03:48 PM Thread Starter
Keyboard Implanted
 
ackerdackerly's Avatar
 
Join Date: Feb 2001
Location: Kansas City, MO
Posts: 2,075
Thanks: 0
Thanked 0 Times in 0 Posts
 
Oops! Hidden damage

I drove 'ol Yellow Wheels out to pick up Jon at summer school... The Transfer Case knob shook like it was in a blender after the completion of each low-speed shift!

I haven't taken a good look at the bottom-side yet, but I expect something is bent!

Crunch, I may need buy a couple of TC mount components (or worse)... I'll let you know by this time tomorrow.

A. Dackerly

ackerdackerly is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-20-2001, 04:54 PM
 
Join Date: Dec 2000
Posts: 2,979
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Oops! Hidden damage

Let me know if you need the armd and mounts. I have some spares lying around.

AARRRRRRRG! 1987 Red JX 'vert, 4.5 BREEZE SPOA, SJ410 T-case (next week), 29 Super Swampers... more to come.... AARRRRRRRG!
Capn_Crunch is offline  
post #3 of (permalink) Old 07-21-2001, 05:46 AM
zukikid
Guest
 
Posts: n/a
Re: Oops! Hidden damage

check your rear drive shaft u joints .might have blown one at the melt
zukikid

proud owner of the SUPER stock zuk. :-)
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 07-21-2001, 09:55 AM Thread Starter
Keyboard Implanted
 
ackerdackerly's Avatar
 
Join Date: Feb 2001
Location: Kansas City, MO
Posts: 2,075
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Oops! Hidden damage

zukikid:

What am I looking for damage-wise? I also checked rear shaft visually while I was underneath it last night. Nothing was lose but I could not turn it as the rear wheels were on the ground. I did remove the rear part of the shaft to flat tow to the Melt, and I did not tie the forward part up since it looked so short and out-of-the-way... Perhaps the front joint is damaged?

There is no visible damage to the T-case or mounts, Capt'n Crunch.

Acker

ackerdackerly is offline  
post #5 of (permalink) Old 07-21-2001, 08:05 PM
 
Join Date: Nov 2000
Posts: 926
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Oops! Hidden damage

did you get the shaft back in right . that could be the prob
TW


Home Pagehttp://home.talkcity.com/SparkplugSt/trailwalker1/
trailwalker is offline  
post #6 of (permalink) Old 07-21-2001, 08:11 PM
patchizuki
Guest
 
Posts: n/a
Re: Oops! Hidden damage

i have a similer vibration at the start of 2nd gear and have been to lazy to replace the ujoints in the intermediate shaft. worth checking

post #7 of (permalink) Old 07-21-2001, 11:29 PM Thread Starter
Keyboard Implanted
 
ackerdackerly's Avatar
 
Join Date: Feb 2001
Location: Kansas City, MO
Posts: 2,075
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Oops! Hidden damage

thanks, guys!

ackerdackerly is offline  
post #8 of (permalink) Old 07-23-2001, 07:24 AM
zukikid
Guest
 
Posts: n/a
Re: Oops! Hidden damage

once again i have been off-board ...the u-joint i found was in the rear drive shaft.the best way to check u-joints are to pull the drive shafts.mark the flangs b 4 you take the drive shafts loose so that they go back in like you took them out .
zukikid

proud owner of the SUPER stock zuk. :-)
post #9 of (permalink) Old 07-23-2001, 07:42 AM Thread Starter
Keyboard Implanted
 
ackerdackerly's Avatar
 
Join Date: Feb 2001
Location: Kansas City, MO
Posts: 2,075
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Oops! Hidden damage

'Kid:
Is it possible that vibration is because I didn't mark the rear flange parts before dissassembly & I reassembled it 180% out of position? The shaft and joints seem nice and tight...

ackerdackerly is offline  
post #10 of (permalink) Old 07-23-2001, 07:57 AM
zukikid
Guest
 
Posts: n/a
Re: Oops! Hidden damage

that could be ... but to tell you the truth...i went through every u-joint in my zuk.the one from the tranny to trans case i had a bad one and in the rear i had a bad u -joint .i also had a bad moter mount and a bad tranny mount .go figure .
zukikid

proud owner of the SUPER stock zuk. :-)
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome