Track Alternator ????? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-10-2001, 10:34 PM Thread Starter
 
Join Date: Dec 1999
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
 
Track Alternator ?????

Got a ? about my 90 tracker. Just got it and its a cherry, 85K and never been off road. I was driving it tonight and it seemed like the lights were flickering. Could I be developing an alternator or voltage regulator problem. I have heard that tracker computers are suspect. Any ideas? Thanks for you input

markmartinbirdie is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-11-2001, 09:31 PM
Addict
 
Zukinator's Avatar
 
Join Date: Feb 2001
Location: Virginia
Posts: 495
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Track Alternator ?????

I would be a little more apt to suspect a loose wire or bad switch. An alternator that is failing will usually discharge your battery as you drive, fading your lights at a slower rate before finally killing your battery completely. With a new fuel injected model, it would also start to miss as your computer, elect. fuel pump, and elect. ign. begin to starve for voltage.

Any parts store should be able to test your batt. and alt. under load for no charge.

Hope this helps.

I'll be back.

Zukinator is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome