Ignition Problems!!! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-29-2001, 11:48 AM Thread Starter
 
Join Date: Jun 2000
Posts: 418
Thanks: 0
Thanked 0 Times in 0 Posts
 
Ignition Problems!!!

Ok here it goes...

After driving my samurai around, when i go to shut it of it hesitates, spit's and sputters and sometimes dies. OTher times i have shut the ignition completly of and pulled the key out and it was still running .. Also sometimes when i goe to shut it off, it sputter's and spits, almost stalls, then suddenly I hear my Starter kick in and turn the engine over.. This is not healthy..

I am not sure if this is some sort of bad wiring or if it is a problem in the ignition switch...


I have an extra ignition switch, Tonight i will swap them and see what happens..

If anyone has any idea's i am open to them..... -Thanks

-How many injuries or mishaps have happend after saying to you friends, "Hey, Watch this!!"
billduck is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-29-2001, 01:09 PM
Addict
 
Zukinator's Avatar
 
Join Date: Feb 2001
Location: Virginia
Posts: 495
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Ignition Problems!!!

Sounds like some post detonation run-on. Sometimes called "dieseling." Most likely your timing is off. There are some other things that could cause it (carbon build up - which affects timing, valves out of adjustment, etc...) but if you haven't changed anything I would focus on the timing first.

I'll be back.

Zukinator is offline  
post #3 of (permalink) Old 06-29-2001, 01:17 PM
Can't Get Enough
 
Scott_CJ8's Avatar
 
Join Date: Sep 1999
Location: Huntersville, NC USA
Posts: 1,435
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Ignition Problems!!!

I agree with Zukinator, could be timing. But it's odd that you hear your starter kick in and turn the engine - that sounds like an ignition short. I'd check all the cables carefully, then maybe swap the ignition switch (great when you got spare parts!). Good luck.
Zukin'

Scott Trester
1988.5 Suzuki Samurai
http://RockPile4x4.tripod.com/Scott.html
Scott_CJ8 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-29-2001, 02:26 PM Thread Starter
 
Join Date: Jun 2000
Posts: 418
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Ignition Problems!!!

Well, I am quite fimiliar with diesiling, and thats not it. It is not the timming ,, I have narrowed it down to electrical problems. It seems almost like there is a bad connection in the ignition switch, it is as if the switches inside are all being turned on at once... When i get home i am going to switch them and see how it goes.

-How many injuries or mishaps have happend after saying to you friends, "Hey, Watch this!!"
billduck is offline  
post #5 of (permalink) Old 06-29-2001, 05:06 PM
Addict
 
Zukinator's Avatar
 
Join Date: Feb 2001
Location: Virginia
Posts: 495
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Ignition Problems!!!

Sounds as though you are on the right track.

I'll be back.

Zukinator is offline  
post #6 of (permalink) Old 06-29-2001, 08:57 PM Thread Starter
 
Join Date: Jun 2000
Posts: 418
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Ignition Problems!!!

Well i swapped ingnition switches,,, but some of the problem contiues... however the starter hasn't kicked in when shutting off, so thats good.

Now when i turn the key it's like the electrical is being delayed/ or it seems like i am stalling the thing out (Spits and sputteres and the whole cab shutters.)

Perhaps i am suffering from diesiling. If so what is a good method of testing / fixing this problem....

-How many injuries or mishaps have happend after saying to you friends, "Hey, Watch this!!"
billduck is offline  
post #7 of (permalink) Old 06-30-2001, 02:22 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Ignition Problems!!!

86-88 Sam when key is turn off breaks +12 to ignition circuit fuel cut off solenoid valve closes which inturn stop engine this if this valve fails to close completely
engine will continue to run until inline fuel is exhuasted.

post #8 of (permalink) Old 06-30-2001, 11:40 AM
Keyboard Implanted
 
ackerdackerly's Avatar
 
Join Date: Feb 2001
Location: Kansas City, MO
Posts: 2,075
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Ignition Problems!!!

'bout all I can add to this is to check the timing as follows:

Put cyl. 1 on Top Dead Center (TDC) by removing it's sparkplug and watching the piston to spot it at it's uppermost position (use a chain-type vice grip around the fan pully to do this). BE SURE TO TURN THE CRANKSHAFT CLOCKWISE OR YOU MAY SCREW UP YOUR TIMING BELT.

Remove the distributor cap. The rotor should be pointing "up" across the engine to the driver's side. If not, turn the crank another full turn so that Piston 1 is again at Top Dead Center (TDC) and the rotor is pointing "up" across the engine to the driver's side.

Carefully note the position of the sparkplug wire on the cap that is nearest to the tip of the rotor.

Loosen the distributor bolt and carefully turn the distributor so that the rotor and the spark plug point inside the distributor line up exactly.

Tighten the distributor bolt and replace the distributor cap.

Does it run better?

Acker


ackerdackerly is offline  
post #9 of (permalink) Old 06-30-2001, 04:35 PM
Addict
 
Zukinator's Avatar
 
Join Date: Feb 2001
Location: Virginia
Posts: 495
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Ignition Problems!!!

You will need a timing light to set the timing properly. Since you have been running ok up till now and you haven't done any work that would change your timing (have you?), I would check the timing with the light prior to pulling the #1 plug. I typically use a little Whiteout or white model paint to mark the notch on the crankshaft and the 10 degree BTC (I think its 8-10 degrees. Might want to check though) on the belt cover. It will make seeing the marks a lot easier. Make sure the engine is at normal operating temp. when setting the timing. If it is off some, loosen the bolt that holds the dist. in place just enough to allow it rotate with some effort or by bumping it with a small mallet or something. Then rotate the dist. until the marks are in line. It is also important to check the rpm of the engine while setting the timing. For a Sami I think it is supposed to be 800 rpm. If it isn't idling at 800 it will falsify the setting. If you aren't electronic ignition you will also want to cap off the vacuum advance.

On a final note sometimes setting by the book will be off a little because of carbon build up on the pistons. If it seems to be close when setting it by the book but is still a little hesitant or your valves ping a little, you may try advancing or retarding by a degree or two which ever seems to make it run the best. Additionally, if you have to turn the dist. excessively in either direction to get the timing marks to line up, your dist. may be off by a tooth or your belt may have jumped. Then you would need to go forward with checking your timing belt, pulling the #1 plug, etc...

If the timing seems to be o.k., you might want to check your valves or the thing KANDO mentioned.

I'll be back.

Zukinator is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome