Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   Suzuki GEO All (https://forums.off-road.com/suzuki-geo-all/)
-   -   HELP!! engine stalls.... (https://forums.off-road.com/suzuki-geo-all/64661-help-engine-stalls.html)

Capn_Crunch 04-05-2001 03:35 PM

HELP!! engine stalls....
 
The Sami has developed a new problem...

Once the engine warms up it will stall when it's under load. It will idle fine but when I engage the clutch and put it in gear then release the clutch it will stall out. The only way I can get the car to run is if I push the RPMs up high and keep them there while I disengage the clutch. The trany is noisy and I suspect that this might be part of the problem but I'm not sure. It's definately not the gas or junk in the tank becasue I just had it drained and cleaned.

Any help would be appreciated.


Farther 04-05-2001 04:46 PM

Re: engine stalls....
 
I would try a new fuel filter, especially after having disturbed all the junk in you fuel tank by cleaning it.

-Farther

Capn_Crunch 04-05-2001 05:26 PM

Re: engine stalls....
 
Did the new fuel filter too...


Farther 04-05-2001 06:02 PM

Re: engine stalls....
 
If you changed the filter at the same time as cleaning the tank, your new filter may have plugged up too.

-Farther

Capn_Crunch 04-05-2001 06:23 PM

Re: engine stalls....
 
I did the filter after the tank. I'll take it off and see if I can blow it out.


Capn_Crunch 04-05-2001 11:37 PM

Re: engine stalls....
 
anyone?


**DONOTDELETE** 04-05-2001 11:58 PM

Re: engine stalls....
 
What kind of card do you have? had the same issue with my Weber. Turned out to be the filter on the carb an some sensor just needed to be cleaned. Haven't had problem since.


**DONOTDELETE** 04-06-2001 12:09 AM

Re: engine stalls....
 
Me speak bad english type worse :)

LOCO


Capn_Crunch 04-06-2001 01:38 PM

Re: engine stalls....
 
stock carb.


**DONOTDELETE** 04-06-2001 02:30 PM

Re: engine stalls....
 
Have no help then. I'm getting pretty good with the weber though.

Sorry,

Damien



All times are GMT -5. The time now is 08:42 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome