My fuel Gauge lying to me? I hate Liars! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-22-2001, 08:57 PM
**DONOTDELETE**
Guest
 
Posts: n/a
My fuel Gauge lying to me? I hate Liars!

I just filled up the tank (as a matter of fact i always keep it filled, or at least try to) and it marks a little below the full mark. can it be faulty? what can i do?

~Goot
http://suzukigoot.rockcrawler.com/
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-22-2001, 09:06 PM
 
Join Date: Dec 1999
Posts: 1,331
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My fuel Gauge lying to me? I hate Liars!

That's better than my fuel gauge. When I fill mine it registers empty. I just use the trip meter.

88.5 Samurai is offline  
post #3 of (permalink) Old 02-22-2001, 09:11 PM
zukiman
Guest
 
Posts: n/a
Re: My fuel Gauge lying to me? I hate Liars!

Sounds like you guys have bad sending units in your gas tanks. I had the same problem with my gauge, but when I put in a new sending unit, the problem was fixed.

--Geoff Beasley

Sponsored Links
Advertisement
 
post #4 of (permalink) Old 02-23-2001, 07:18 AM
Old Hand
 
Jbird's Avatar
 
Join Date: Sep 1999
Location: Little River, South Carolina
Posts: 763
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My fuel Gauge lying to me? I hate Liars!

I've always heard that Zuks gas gauges go bad. I always considered myself lucky because my gauge worked perfect. Then one day my gauge did what yours did, I filled up but the gauge showed just below full. As an experiment the next time I filled up I kept squeezing more fuel in. I was determined to make sure it was filled. I had to put the gas in super slow but I put in over a gallon more! In a Zuk that's a lot! The gauge showed full!

So I don't know what changed in the gas tank but something did because I never had to squeeze in an extra gallon before. But it's still like that to this day. I checked all of my vent hoses and everything looks OK.

[img]/wwwthreads_images/icons/cool.gif[/img][email protected]
http://www.geocities.com/jbird88_5/index.html
Jbird is offline  
post #5 of (permalink) Old 02-23-2001, 07:43 AM
Keyboard Implanted
 
Yankee Tim's Avatar
 
Join Date: Mar 2000
Location: Northern Catskill Mountains, NY
Posts: 4,756
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My fuel Gauge lying to me? I hate Liars!

The one good thing about Sammy gas gauges is when they say empty, it's not empty! Mine seems to have a reserve tank. Below E, there are two little dots. It's about 4-5 liters left between the dots. When it gets to the lower dot, you're out. And in a EFI Sammy, running out of gas too often is VERY bad for the expensive fuel pump.

On the issue of toping of the tank, some sammy's need to be "burped". Mine doesn't. When the handle clicks off for full, I'm hard pressed to squeeze another $.25 in to it.

I always carry a 5-gal. Gerry can of gas, a half a tank to stow!

<font color=blue>Yankee Tim</font color=blue>[img]/wwwthreads_images/icons/cool.gif[/img]
Yankee Tim is offline  
post #6 of (permalink) Old 02-23-2001, 08:44 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: My fuel Gauge lying to me? I hate Liars!

What all is involved in changing a sending unit?

JC Garrett
91 Samurai JS
[email protected]
post #7 of (permalink) Old 02-23-2001, 12:48 PM
 
Join Date: Sep 2000
Posts: 710
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My fuel Gauge lying to me? I hate Liars!

Goot,
Mine does the same thing. Also the top half of the tank seems to go way faster than the bottom half. What I mean is, when I fill it up and drive to work my gauge drops to half a tank, but that half of the tank will last 3 or 4 more days before I have to put gas in. It's really weird.

"Ahhhh.... He wants to go off-road!!!!" -Ace Ventura
http://suzukisteve.rockcrawler.com
smitche is offline  
post #8 of (permalink) Old 02-23-2001, 02:27 PM
 
Join Date: Jul 2000
Posts: 1,355
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My fuel Gauge lying to me? I hate Liars!

Seems as if these things have their moods,days, whatever.When mine reads half its really empty trust me its put me to walking.Ive got 88.5s theory:trip meter reads 180(for mine)fill er up!

87"dug from the grave"zuk[img]/wwwthreads_images/icons/tongue.gif[/img]
Best mod-it runs,finally!!![img]/wwwthreads_images/icons/laugh.gif[/img][img]/wwwthreads_images/icons/crazy.gif[/img]
87 XJ 4.0 with about a squillion miles and wont quit.Do they ever die?[img]/wwwthreads_images/icons/cool.gif[/img]
mudslide is offline  
post #9 of (permalink) Old 02-23-2001, 04:07 PM
 
Join Date: Jul 2000
Posts: 303
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My fuel Gauge lying to me? I hate Liars!

Have anyone put a Autometer fuel gauge??
Does the sending unit works for the Zuk?
Crzook

86 Samy/1600/weber/header/rear locker/33's/warn8000/mud?
San Jose, Costa Rica
crzook is offline  
post #10 of (permalink) Old 02-24-2001, 06:50 PM
 
Join Date: Jul 2000
Posts: 1,355
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: My fuel Gauge lying to me? I hate Liars!

Yeah,but you would still need to hook in to the gas tank sending unit to get a read though,right?

1 cross plus
3 nails
----------------
4 given [img]/wwwthreads_images/icons/wink.gif[/img]
mudslide is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome