Bad noise in 4WD - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-08-2000, 02:25 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Bad noise in 4WD

Guys a little advice would be appreciated.

The past 3 or 4 times I've had my 95 4dr 4wd Kick out off-roading I have been hearing a strange noise from the front end.

This noise can best be described as a LOUD clicking or binding of metal on metal.
It only happens at very low speeds when climbing obstacles or pulling someone out (developing maximum torque while barely moving). It has nothing to do with whether the wheels are pointed straight or turned so I don't think it's the CV joints. My idea is that it could be my auto hubs possibly engaging and partially disengaging, when I shift out of 4wd and go in reverse to disengage the hubs you hear a quiet click, the noise I'm trying to describe is similiar only MUCH louder.

I do have the Haynes manual but have never taken the front driveshaft apart and have no clue as to the mechanical workings of the Auto hubs. If anyone has had this happen or has an idea your response would be greatly appreciated.

The Kick still drives fine but I'm thinking this noise can't be good and don't want to make the situation worse by continuing to drive it off-road before fixing this.

Thanks
Eric


Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome