Repair CMP sensor - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-07-2000, 10:38 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Repair CMP sensor

My 92 4dr (16 valve MPFI) sidekick won't start. The error code reported is 42, the camshaft position sensor.
The dealer says he doesn't show the CMP as a replacement part, I need to buy a new distributor for $400.
Anyone have an idea how to repair/replace the sensor?

TIA


Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-07-2000, 10:56 AM
 
Join Date: Dec 1999
Posts: 1,331
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Repair CMP sensor

My bro had the same problem and his turned out to be a bad rotor button. You could try Hawk Suzuki 1-888-SAMURAI. Ask for Ted.

88.5 Samurai is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome