extreme loss of ass - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-18-2008, 08:02 AM
zuk4climbn'
Guest
 
Posts: n/a
extreme loss of ass

ok, so i replaced my valve cover gasket because it was bleeding like a stuck pig. in the process i found two screws in the corner of the valve bay. they mated up to the rocker covers on the passener side of the rear two assemblys. tightened them and all the others down and replaced the valve cover. put my plug wires back on in the proper order. started it up (noticing a drastic decrease in exhaust noise. i think i had a leak before, at leist it sounded like, after the screw replacement it disappered.) and went for a test drive. now i thought i didnt have any ass before, i really dont have any now. what is my problem?? any thoughts will be a real help.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-18-2008, 10:49 AM
Addict
 
James_Holland's Avatar
 
Join Date: Jul 2002
Location: High Wycombe, UK
Posts: 321
Thanks: 0
Thanked 0 Times in 0 Posts
 
Quote:
Originally Posted by zuk4climbn' View Post
ok, so i replaced my valve cover gasket because it was bleeding like a stuck pig. in the process i found two screws in the corner of the valve bay. they mated up to the rocker covers on the passener side of the rear two assemblys. tightened them and all the others down and replaced the valve cover. put my plug wires back on in the proper order. started it up (noticing a drastic decrease in exhaust noise. i think i had a leak before, at leist it sounded like, after the screw replacement it disappered.) and went for a test drive. now i thought i didnt have any ass before, i really dont have any now. what is my problem?? any thoughts will be a real help.

Did you check the valve lash while you were in there?

2000 Vitara 1.6, 2" lift, 3" body lift, winch, snorkel, safari rack, 33" MTs, rear discs, steel front axle, 5:83s
SJ413K Pick Up, 1.6 conversion.
James_Holland is offline  
post #3 of (permalink) Old 01-20-2008, 08:22 AM
zuk4climbn'
Guest
 
Posts: n/a
no i didnt. how do i do that. im kinda retarded when it comes to that.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome