carb problems? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-15-2007, 08:31 PM
katzer
Guest
 
Posts: n/a
carb problems?

New member, new sami owner. I have a 87 sami that has started to stutter when accelerating. It seems to do it in all gears at the middle to upper RPM range in the gears. It is at its worst when the motor is cold and is more prevelant in 1st 2nd and 3rd gears. I have also noticed my gas mileage go from 24 to 16 mpg. I think it may be flooding itself, because there is a gas odor when it does it, and by the way it chugs along it is either flooding or not getting enough fuel. Is this the vent tube problem that is posted on every zuk page or something else. Any help would be greatly appreciated.
katzer
Note the thing idles great both cold and warm.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome