Ecu Interchange?? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-14-2007, 03:53 PM
SCOTTYFIREMAN
Guest
 
Posts: n/a
Ecu Interchange??

My Ecu Is 33920-56b30
Can I Use A 33920-56b51??
Does Any One Know What All Other Numbers Will Work With My Geo??

I Have A 1991 Geo
8v 5 Speed 4x4 With A/c
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-15-2007, 09:38 PM
Apprentice
 
AUGETER's Avatar
 
Join Date: Oct 2002
Location: San Marcos,Ca
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
 
Ecu Swap?

Your computer # 33920-56B30 indicates an 8V . #33920-56B51 should be for a
1994 16V motor w/auto. According to the #'s they will not interchange. The 56B30 was used up through 1994 so there is a good chance of finding one. The next question is why do you want to change ECU's? If yours is bad-no power to
injector-then it is very easy to repair it or there are several people on this board who will do it very reasonably. Just do a search on ECM Repairs. Good luck!
AUGETER is offline  
post #3 of (permalink) Old 12-16-2007, 04:01 PM
Keyboard Implanted
 
ackerdackerly's Avatar
 
Join Date: Feb 2001
Location: Kansas City, MO
Posts: 2,075
Thanks: 0
Thanked 0 Times in 0 Posts
 
Ecu

There is a guy named "surly" at Zuwharrie.Com who lurks in the BBS (or Forum) section that knows a great deal about ECUs.

Try a post there.

Ack
Ack's FAQ
nearly 837 searchable links to Suzuki/Geo modding and maintenence info - including the Tracker FSM Project!
'88 "SJ-416 Samurai"
'11 Ford Transit Connect XLT
ackerdackerly is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 12-17-2007, 07:25 AM
SCOTTYFIREMAN
Guest
 
Posts: n/a
Thanks guys..... and yes mine is bad.... No injector pulse...... No fuel pump power..... No spark......

I did the caps replacement but that didnt help it any......
post #5 of (permalink) Old 12-31-2007, 12:45 PM
SCOTTYFIREMAN
Guest
 
Posts: n/a
OK... UPDATE........

After the caps replacement I now have fuel pump power and spark......

But still no injector power????
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome