2WD tranny problems - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-27-2007, 03:10 PM
redlines4me
Guest
 
Posts: n/a
2WD tranny problems

my 95 2wd/ auto Tracker is having tranny problems, especially in the morning or after it set for a few hours. It starts out fine,but, once it hits third gear nothing, it won't go. After awhile when it warms up it's better but not 100%. Is this a vacuum problem? Maybe my fluid and filter need cleaning? Any help would be appreciated. Thanks
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-27-2007, 06:57 PM
Old Hand
 
tuneman's Avatar
 
Join Date: Aug 2002
Location: blackstone,ma
Posts: 524
Thanks: 0
Thanked 0 Times in 0 Posts
 
id hate to give ya bad news but my 90 tracker auto did this and then it crapped out on me
try this in the morning when it shifts into drive and there is nothing there pull it down to 2nd the back into drive and it should shift up at least thats what mine did
good luck

88.5 sami zuk 5 speed,jeep t15 3speed,thorley header,centerforce2 toy steering toy axles 529's welded f+r full cage race seats and dents
tuneman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome