95 Geo Tracker Engine Surge???? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-06-2007, 01:07 PM
sled600
Guest
 
Posts: n/a
Cool 95 Geo Tracker Engine Surge????

This is driving me nuts.
I recentkly bought a 95 Geo Tracker. 1.6 16v MFI. Ran great for 2 weeks. then started a "surge" and losing power on the road. I did a good tune-up- replaced the timing belt just because....Replaced the fuel pump and filter. All with no change!!!! I spent $200 at a shop to diagnose the issue. They told me it was the fuel pump.

I don't see any vacuum leaks.

Seems to be getting slightly worse as time goes on.

I can only go 45 mph over snoqualmie pass (did it at 65 just after I bought the rig). It had sat for about a year before I bought it.

No Check engine light issues.

Any ideas??

Thanx in advance!
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome