Need Help! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-30-2007, 06:51 AM
Larry Hatcher
Guest
 
Posts: n/a
Need Help!

We put the 95 Geo motor into the 90 body! We did have to use the old dist. because of the vac. advance! 95-had elec. advance! Info from computer says the 90 dist. turns clock-wise....an the 95 turns counter! Fireing order is back-wards! Will this dist. not work? Its firing at the plugs but not in time!..Number 1 plug is set on the 1st cyl..........could I just b 180-degrees off? Will I hav to make the newer dist. work? any-help would b great!!

Thanks Guys!
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-30-2007, 07:18 AM
Addict
 
James_Holland's Avatar
 
Join Date: Jul 2002
Location: High Wycombe, UK
Posts: 321
Thanks: 0
Thanked 0 Times in 0 Posts
 
Quote:
Originally Posted by Larry Hatcher View Post
We put the 95 Geo motor into the 90 body! We did have to use the old dist. because of the vac. advance! 95-had elec. advance! Info from computer says the 90 dist. turns clock-wise....an the 95 turns counter! Fireing order is back-wards! Will this dist. not work? Its firing at the plugs but not in time!..Number 1 plug is set on the 1st cyl..........could I just b 180-degrees off? Will I hav to make the newer dist. work? any-help would b great!!

Thanks Guys!
Is the 95 motor a 16V?

2000 Vitara 1.6, 2" lift, 3" body lift, winch, snorkel, safari rack, 33" MTs, rear discs, steel front axle, 5:83s
SJ413K Pick Up, 1.6 conversion.
James_Holland is offline  
post #3 of (permalink) Old 04-30-2007, 05:34 PM
Keyboard Implanted
 
zooky's Avatar
 
Join Date: Nov 1999
Location: New Hampshire
Posts: 2,844
Thanks: 0
Thanked 0 Times in 0 Posts
 
Exclamation

Quote:
Originally Posted by Larry Hatcher View Post
We put the 95 Geo motor into the 90 body! We did have to use the old dist. because of the vac. advance! 95-had elec. advance! Info from computer says the 90 dist. turns clock-wise....an the 95 turns counter! Fireing order is back-wards! Will this dist. not work? Its firing at the plugs but not in time!..Number 1 plug is set on the 1st cyl..........could I just b 180-degrees off? Will I hav to make the newer dist. work? any-help would b great!!

Thanks Guys!
too many explanation points!!!!!

Bacon is quite wonderful
Bacon is quite good
I would eat it every day
If I freakin could
zooky is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 05-09-2007, 06:45 AM
Larry Hatcher
Guest
 
Posts: n/a
Electric Fuel pump-Geo

1990-Geo..........fuel pump is gone.........how do you take the old one out of tank? Does it twist? if so which direction?It has several phillip-screws on top.....? Does anyone out there have a good used one or have found a less expensive one that works? My timing was 180 degrees off! It solved my timimg issue.......thanks for the help Guys!!!
L. Hatch
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome