Backfire through carb - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-25-2007, 06:58 PM
moonroe
Guest
 
Posts: n/a
Exclamation Backfire through carb

Sorry if this is on here somewhere....I couldn't find it...I recently had my 8v1.3 rebuilt....I followed the FSM to the T...now it wont start....and when i turn it over it backfires through the carb....WTF....I have tried everything i know....any help would be greatly appreciated...Thanx in advance
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-25-2007, 07:38 PM
Keyboard Implanted
 
Join Date: Nov 2001
Location: North Central Illinois
Posts: 3,928
Thanks: 0
Thanked 0 Times in 0 Posts
 
Sounds like the cam timing is off , verify the distributor indexing as well as your cam belt . If nothing else, rotate the engine with all four plugs out and note when #1 starts showing compression with a guage or by hand. At that point #1 is approaching TDC , align the timing marks on the flywheel at the timing port in the driver's side of the trans bellhousing . With the crank indexed to #1 you can now match the distributor to #1 cylinder .
Sarge

Midwest Performance Parts
Weber Modifications/Rebuilds & Parts
Sarge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome