No Fuel - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-07-2005, 01:04 PM Thread Starter
 
Join Date: Sep 1999
Posts: 385
Thanks: 0
Thanked 0 Times in 0 Posts
 
No Fuel

I have a 1990 Samurai with stock fuel injection. After about six weeks of sitting up, I tried to crank it up this weekend and it wouldn't crank.

If I dribble gasoline into the throttle body, it cranks and runs fine, but it will not run on its own. So obviously, I have a fuel problem.

Since the fuel pump is in the gas tank, is there an easy way to test it without taking it out?

Any other ideas?

thanks,
James
James Hiers is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-07-2005, 01:12 PM
 
Join Date: Oct 2003
Posts: 534
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: No Fuel

Discconect it up by the engine and see if anything comes out.
mug_Shot is offline  
post #3 of (permalink) Old 02-07-2005, 11:18 PM
 
Join Date: May 2004
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: No Fuel

If you turn the key to on, but not start, you should be able to hear the fuel pump running for 3 seconds or so til it shuts itself off.
Lil_Red is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome