91 efi in a 88 sammy - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 11-01-2004, 11:13 PM
Mark_Chaney
Guest
 
Posts: n/a
91 efi in a 88 sammy

I have an 88.5 sammy that i installed a 91 fuel injection kit on it about three or four years ago. it has ran great until just recently. now it hesitates on acceleration but only intermittently. sometimes it runs great other times I can get it to move two feet be fore it dies. I sent the ECM off to be rebuilt but that didn't seem to help. I get a code 14,sometimes a code 24, sometimes a code 45. I cannot get voltage (Which according to the service manual should be 4-5 volts) at the gray wire with the red strip at the tps. and I cannot get voltage to the coalant temp sensor wich is the red wire with the white strip. I can however get voltage out of the back of the ECM but only on A23, not A18 and only when I use A24 as the ground I cannot get voltage if I use the engine or chassis as ground. I've traced wires till I blue in the face is there anyone out there that can help. Most people tend to say that I'm over there head on this one. Granted I have not sent the ECM back yet to get it rechecked but the rebuilder insists that it was tested in a sammy before they sent it. I wanted to rule out anything that might cause this from my side first before I spend another $250.
This is a complicated problem and it may easeir to discuss over the phone. If you like e-mail me with a time and phone number and I will call you. if not this forum will be fine to.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 11-02-2004, 12:31 AM
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 91 efi in a 88 sammy

Hi, and welcome to the board.
I have been in your shoes ---EXACTLY same symptoms.
My problem was grounds.
Then ECM went out and I replaced the three caps in the ecm.
Haven't had any more problems since.
Pull all grounds make them shine and re-install.
Especially make sure the ground from the disty to the firewall is intact. That one tends to corrode inside the plug and insulation.
HTH
Dale
AkDale is offline  
post #3 of (permalink) Old 11-02-2004, 12:40 PM
Mark_Chaney
Guest
 
Posts: n/a
Re: 91 efi in a 88 sammy

That sounds reasonable. I'll try it!! what do you mean by "replace the three caps on the ecm" what are the caps?

Thanks,

Mark Chaney
Eastland TX, 76448
88.5 sammy 91 EFI
Thorley Header
Isky cam
4 to 1 TCase
31x10.50 BFG's
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 11-02-2004, 06:46 PM
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 91 efi in a 88 sammy

There are three capacitors (SP?) soldered on the circuit board that sometimes leak and go bad. The stuff that leaks out smells like rotten eggs. This stuff corrodes the copper bridges on the circuit board and the board doesn't work any more. If you do not have experience at working with printed circuits, I would advise you not to try to learn on your ECM---Unless you have another one. [img]images/graemlins/crazy.gif[/img]
AkDale is offline  
post #5 of (permalink) Old 11-02-2004, 08:28 PM
 
Join Date: Feb 2001
Posts: 1,316
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 91 efi in a 88 sammy

i would also suggest checking out any grounds you have.

on a somewhat unrelated subject, i just had a efi sammy die and the reson was the fuel pump bracket had deteriorated to the point it was crumbly and it would not conduct a ground from the in tank pump anymore, hence it was dead as the fuel pump did not function without the ground.

check your grounds once again.
blue_zuk is offline  
post #6 of (permalink) Old 11-05-2004, 11:30 AM
Mark_Chaney
Guest
 
Posts: n/a
Re: 91 efi in a 88 sammy

Well I made all the grounds shine. and even relaced the negative battery cable. checked all the connections. everything seems fine. But it still is doing the same things. So I pulled out the ECM and sent it back to the rebuilder. does anybody have any other ideas?
post #7 of (permalink) Old 11-05-2004, 11:38 AM
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 91 efi in a 88 sammy

Are you using the FSM to troubleshoot?
AkDale is offline  
post #8 of (permalink) Old 11-08-2004, 11:10 AM
Mark_Chaney
Guest
 
Posts: n/a
Re: 91 efi in a 88 sammy

Yes I have both the 88-90 and the 91-94 supplement FSM.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome