worn plug? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-21-2004, 12:00 PM Thread Starter
 
Join Date: Apr 2004
Posts: 193
Thanks: 0
Thanked 0 Times in 0 Posts
 
worn plug?

finaley finished the motor change and found #3 had been sort of striped any idea's? [img]images/graemlins/cussing.gif[/img]
fgm1 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-21-2004, 07:50 PM
Keyboard Implanted
 
Join Date: Nov 2001
Location: North Central Illinois
Posts: 3,928
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: worn plug?

You can try a rethreading tool , if that doesn't work you'll have to get a helicoil kit and put an insert in it .
Sarge
Sarge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome