electrical - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-14-2004, 01:49 PM Thread Starter
 
Join Date: Jul 2003
Posts: 351
Thanks: 0
Thanked 0 Times in 0 Posts
 
electrical

I've been having an electrical problem. My battery doesnt seem to be getting charged while im running it by the alternator. The battery holds a charge pretty well but for some reason the alternator doesnt charge it.

I've checked the grounds and they all seem to be in good shape. Im charging the battery now and im gonna drive up to advance auto and have them do another battery and alternator check. I'm running the 1.6 16 valve settup.

I read some posts to where people were having trouble with their tach and it was wiring related. When the battery first drained I had to have someone tow me back home(about 5 miles) I had the t-case in neautral, but the rpms were going as high as they could possibly go...over 12000....is this normal while towing or think this is an electrical problem? The key was turned so that the steering wheele wouldnt lock.

Even if its not related...what else should I check?
gravtyklz is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-14-2004, 01:53 PM Thread Starter
 
Join Date: Jul 2003
Posts: 351
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: electrical

It all started when it was raining one day...have no idea if that makes a difference or not.
gravtyklz is offline  
post #3 of (permalink) Old 04-14-2004, 02:11 PM Thread Starter
 
Join Date: Jul 2003
Posts: 351
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: electrical

in adition to the whole tach thing....when I take the key out sometimes the tach stays where ever it was last...then when I put the key in and durn it on it will go back down(not turning the engine on..just the power)
gravtyklz is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 04-14-2004, 07:52 PM Thread Starter
 
Join Date: Jul 2003
Posts: 351
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: electrical

from the alternator how does it get to the battery? I see one wire going into the drivers side of the motor and another wire going back into the sammi where the computer is.
gravtyklz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome