Lock-out hub replacement - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-30-2004, 08:23 AM Thread Starter
Can't Get Enough
 
Scott_CJ8's Avatar
 
Join Date: Sep 1999
Location: Huntersville, NC USA
Posts: 1,435
Thanks: 0
Thanked 0 Times in 0 Posts
 
Lock-out hub replacement

OK, so I got a set of manual lockouts to replace my auto hubs on my X-90. They seem to be in good shape and working. Not installed yet. I can see the mechanism locking/unlocking. However, one of the hubs seems to have a bit of play. The inner workings seem to shift around a bit on one and not on the other, which seems snug. I obviously want to grease them. But could that minor bit of slop be a problem? I've never had hubs off before to see how they work. I assume that once on, it will snug up to the axle and not rattle. Any info or advice? [img]images/graemlins/confused.gif[/img] Thanks
Scott_CJ8 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome