Weird electrical problems on Sidekick - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-10-2004, 05:37 AM
riversurfer
Guest
 
Posts: n/a
Weird electrical problems on Sidekick

Last night my '89 kick quit on the way home. I found that it would start and run okay with the lights off, but any lights on would cause the engine to run rough and stop. The brake lights and turnsignals also cause the engine to quit. When the engine is running, with the lights turned off, all the lights, except the headlights, glow dimly, with the turnsignals being the brightest. There is no glow if the engine is not running. Has anyone else had this problem, or have any ideas where to look for the problem? Thanks.

Joe
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-10-2004, 07:02 PM
NS_Wizzard
Guest
 
Posts: n/a
Re: Weird electrical problems on Sidekick

Sounds like an Alternater problem. Try Starting your Side Kick and disconnecting the posiative side of the battery. If the engine dies then most likely that will be the problem. The reason that your car is dropping when your signals or lights are on is because you are running all the electrical system including the firing of the spark plugs. P.S. you might want to take your Battery to that parts store and and have it charged, Sound like ya killed it. Hope this helps .
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome