Success!! Thanks to All! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-21-2003, 07:07 PM
auminer
Guest
 
Posts: n/a
Success!! Thanks to All!

The Samurai is finally running fantastic! Thanks to all of you that gave me ideas as to what to check. While I have been waiting for the FSM to arrive (dealer ordered wrong manual [img]images/graemlins/frown.gif[/img]) I noticed the distributor was not even close to the center of the adjustment so I decided to check the timimng belt. 2 teeth missing and the crank was off 3 teeth to the cam gear. Someone had relocated the distributor in order for it to run so I had to reinstall that. Runs like a champ...for a 1.3. Funny how it would run good up to a certain rpm then crap out. Well, thanks again for all of your input!

auminer
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-21-2003, 07:40 PM
Addict
 
Join Date: Apr 2002
Location: Carrollton, Georgia
Posts: 576
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Success!! Thanks to All!

Glad that you found it, I knew it kinda sounded like what mine was doing when the belt was a tooth off. Good luck with it.
Steve
Bowdon Ga
ka4yqi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome