HELP! Zuk won't start - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-19-2003, 06:59 AM Thread Starter
 
Join Date: Oct 2003
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
 
HELP! Zuk won\'t start

So I take my Zuk to the store the other day and drive it back home, 20 minutes later I come out and get in it and it won't start. Engine cracks and cracks but nothing. Battery is fine but none of my dash lights come on. The next day I go out and she starts right up. Worked fine for the next 2 weeks and then the other day I drove it to the mall and turned it off and it would not start back up. Same thing, no dash lights but everything else worked fine even all my auxilary lights. HELP!

[img]images/graemlins/cussing.gif[/img]
Zuk_mongoose is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-19-2003, 07:06 AM
 
Join Date: Jan 2003
Posts: 239
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

</font><blockquote><font class="small">In reply to:</font><hr />
then the other day I drove it to the mall and turned it off and it would not start back up

[/ QUOTE ]


Brent,
I think that says it all.......lol

STAY OUTTA THE DAMN MALL

j/k

anywho, check all your battery connections and the check all your grounds, ie, distributor to firewall, battery to firewall.
n0lan is offline  
post #3 of (permalink) Old 12-19-2003, 07:08 AM Thread Starter
 
Join Date: Oct 2003
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

Can't help it dude, that is where my girl makes all MY money. [img]images/graemlins/grin.gif[/img]

Thanks dude, I'll definitely check my connections.
Zuk_mongoose is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 12-19-2003, 08:01 AM
 
Join Date: Jan 2002
Posts: 334
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

To start the truck you need two things, fuel and spark. Check that your wires, cap, and the thinkg that the cap connects to. Sorry having a brain fart right now and can't think of it. I will be hard to diagnose because its intermittent.

Good Luck!
Lil_Mudder is offline  
post #5 of (permalink) Old 12-19-2003, 09:32 AM
 
Join Date: Nov 2001
Posts: 734
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

It may be your samurai is mad at you for driving it to the mall [img]images/graemlins/grin.gif[/img] J/K

Take a look at the EFI (fuel pump) fuse in the fuse block and make sure it's o.k. and not corroded or lose in the .
DOABLE is offline  
post #6 of (permalink) Old 12-19-2003, 09:45 AM Thread Starter
 
Join Date: Oct 2003
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

I will for sure check that out. I have my fuel pump on a manual switch and the fuse probably operates the injectors right?
Zuk_mongoose is offline  
post #7 of (permalink) Old 12-19-2003, 09:50 AM
 
Join Date: May 2002
Posts: 2,890
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

A couple of good sugestions there, but I want clarification. Does "It did not start" mean it won't turn over?
Or that it turned over and didn't fire?

My initial sugestion, laking clarification, is to pull th terminals off the battery posts, clean the black oxide
off the posts and the ID of the clamps, and make sure there tight. For some reason this is the time of
year for this to happen. (posts getting black oxide, not quiting at the mall! LOL)
outlawmws is offline  
post #8 of (permalink) Old 12-19-2003, 09:53 AM Thread Starter
 
Join Date: Oct 2003
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

Yeah, it does turn over but no fire. The fuel pump is on and it cracks over fine just no spark I guess.
[img]images/graemlins/thud.gif[/img]
Zuk_mongoose is offline  
post #9 of (permalink) Old 12-19-2003, 03:17 PM
SPAMurai
Guest
 
Posts: n/a
Re: HELP! Zuk won\'t start

Had a simlar problem. Certain accessories would work but not others. Was bad wiring in the ignition switch (where the key goes in &amp; turns). Good luck,
Steve O'
post #10 of (permalink) Old 12-22-2003, 07:03 AM Thread Starter
 
Join Date: Oct 2003
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: HELP! Zuk won\'t start

Is there an easy way to get to the ignition wearing without taking the whole dash apart?

[img]images/graemlins/givemebeer.gif[/img]
Zuk_mongoose is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome