Changed starter, turns over but won't fire - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-08-2003, 05:51 PM Thread Starter
 
Join Date: Dec 1999
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
 
Changed starter, turns over but won\'t fire

We changed the starter on my son's Sam yesterday and now it wont fire up. The starter is turning the motor over fine but we are not getting fire to the plugs, we checked to see if we pulled any wires loose and didnt see any. Are there fuses somewhere that might keep it from firing up. Its a 90 model with FI

Thanks

Mark
markmartinbirdie is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-08-2003, 05:58 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Changed starter, turns over but won\'t fire

Have you checked the coil and the coil wires?
post #3 of (permalink) Old 12-08-2003, 06:15 PM Thread Starter
 
Join Date: Dec 1999
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Changed starter, turns over but won\'t fire

can I check the coil with a meter while turning the motor over?
markmartinbirdie is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 12-08-2003, 08:43 PM
 
Join Date: Jul 2003
Posts: 351
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Changed starter, turns over but won\'t fire

I had to change the starter in my sammi and I had the same problem...but mine was a stupid mistake...I just didnt plug all the coil wires up exactly like they were.

Double and tripple check that you plugged everything up just like it was supposed to be. And it wouldnt hurt to make sure you didnt blow any fuzes while you were installing the starter.

I dont see why you couldnt test the coil wires with a meter either....never had to try that myself but there should be power.
gravtyklz is offline  
post #5 of (permalink) Old 12-08-2003, 09:43 PM Thread Starter
 
Join Date: Dec 1999
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Changed starter, turns over but won\'t fire

what fuses would keep it from cranking?

Thanks
markmartinbirdie is offline  
post #6 of (permalink) Old 12-09-2003, 10:04 AM
Can't Get Enough
 
Brown29's Avatar
 
Join Date: Sep 1999
Location: Arkansas
Posts: 1,426
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Changed starter, turns over but won\'t fire

</font><blockquote><font class="small">In reply to:</font><hr />
what fuses would keep it from cranking?


[/ QUOTE ] The ignition fuse. First fuse on the left bottom row of the under dash fuse box.

The fusible link would also keep it from cranking, but that would make the starter not turn over either, so that's not it.
Brown29 is offline  
post #7 of (permalink) Old 12-09-2003, 10:19 AM
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Changed starter, turns over but won\'t fire

Mine did the same thing.
Replace the ground that goes from the dist to the firewall.


Mine did not appear to be broken, but when I replaced it, all was well. Use a jumper wire with gator clips to test.
AkDale is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome