stupid question - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-16-2003, 02:18 PM
kahless92
Guest
 
Posts: n/a
stupid question

i had my father in la adjust the timeing on my sidekick, anyway he did not jump the wires to do it right,
My question since he did not adjust the timing properly is it possible that the timing becane advanced too far cuasing a miss and vavle ticking? i do not get a a ping like bad gas or advanced but my vavles seem real loud after adjustment and i have a miss... not at idle or when driving normally... but when driving around a parking lot at low rpm (1500 to 2500)
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-16-2003, 07:33 PM
kahless92
Guest
 
Posts: n/a
Re: stupid question

come on guys really need some info here.....
post #3 of (permalink) Old 09-16-2003, 11:28 PM
Keyboard Implanted
 
Join Date: Nov 2001
Location: North Central Illinois
Posts: 3,928
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: stupid question

First off , get it timed correctly before you damage it . Second, try adjusting those valves while the oil is still hot .
Sarge
Sarge is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-17-2003, 08:56 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: stupid question

Sarge said it all!>>>>>>>>>>3 [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img]
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome